Bug 1004500 - anaconda crashes with python error immediately after starting PXE install
anaconda crashes with python error immediately after starting PXE install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
arm Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 14:37 EDT by Mark Langsdorf
Modified: 2013-09-04 14:59 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 14:59:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Langsdorf 2013-09-04 14:37:56 EDT
Description of problem:
I'm trying to install f20-alpha-tc3 on a Calxeda Midway system via PXE. Immediately after anaconda starts, it complains about an inability to install a Python module and errors out.


Version-Release number of selected component (if applicable):
anaconda-20.9-1

How reproducible:
Attempt to PXE install fedora 20-alpha-tc3 on Calxeda Midway hardware via PXE using the kickstart below. Failure is 100% consistent.

Actual results:

Starting installer, one moment...
anaconda 20.9-1 for Fedora 20-Alpha-TC3 (pre-release) started.
16:03:01 Not asking for VNC because of an automated install
16:03:01 Not asking for VNC because text mode was explicitly asked for in kickstart
Traceback (most recent call last):
  File "/sbin/anaconda", line 985, in <module>
  File "/sbin/anaconda", line 615, in setupDisplay
    anaconda.initInterface(addons)
  File "/usr/lib/python2.7/site-packages/pyanaconda/__init__.py", line 205, in initInterface
    self._intf = TextUserInterface(self.storage, self.payload,
  File "/usr/lib/python2.7/site-packages/pyanaconda/__init__.py", line 155, in storage
    if self.instClass.defaultFS:
  File "/usr/lib/python2.7/site-packages/pyanaconda/__init__.py", line 90, in instClass
    from installclass import DefaultInstall
  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 239, in <module>
    baseclass = getBaseInstallClass()
  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 215, in getBaseInstallClass
    allavail = availableClasses(showHidden = 1)
  File "/usr/lib/python2.7/site-packages/pyanaconda/installclass.py", line 187, in availableClasses
    obj = loaded.InstallClass
AttributeError: 'module' object has no attribute 'InstallClass'

Pane is dead

Expected results:
installation.

Additional info:
the system is live after the failure and I can use tmux to enter the shell, so it should be possible to get more information.

here's the kickstart file I'm using:
mlangsdorf@swdev2:~$ cat /data/fedora/kickstarts/f20-highbank.ks 
# Perform a basic Fedora 20 ARM (Highbank) Hard-FP install

lang en_US.UTF-8
#logging --level=info
keyboard us
timezone --utc US/Central
auth --useshadow --enablemd5
selinux --enforcing
firewall --enabled --service=mdns,ssh
network --bootproto=dhcp --device=eth0 --onboot=on --activate --hostname=calxeda-f20-v7hl
services --enabled=NetworkManager,sshd,chronyd --disabled=network

# Only use this with Anaconda for serial console installs, not with livemedia-creator.
#cmdline
text
skipx

# Set a default root password for Fedora
rootpw --plaintext fedora

# Repositories
# apparently we must use 'url' for the install repo for livemedia-creator
url --url="http://dl.fedoraproject.org/pub/alt/stage/20-Alpha-TC3/Fedora/armhfp/os/"
#repo --name=fedora --baseurl="http://dl.fedoraproject.org/pub/fedora/linux/development/20/armhfp/os/"
repo --name=fedora --baseurl="http://dl.fedoraproject.org/pub/alt/stage/20-Alpha-TC3/Fedora/armhfp/os/"

#
# Define how large you want your rootfs to be
#
bootloader --extlinux
zerombr
clearpart --all
part /boot --size 500 --fstype ext3 --label=boot
part swap --size 4000 --label=swap
part / --size 5000 --grow --fstype ext4 --label=rootfs


# Reboot after the installation is complete.
reboot


#
# Add all the packages after the base packages
#
%packages
@standard

# apparently none of the groups sets the clock.
chrony

# and ifconfig would be nice.
net-tools

%end


# more configuration
%post --erroronfail

# make sure we only provision once (avoid reprovision loop)
{% snippet 'clear_netboot' %}

%end
Comment 1 David Shea 2013-09-04 14:43:44 EDT
Can you attach any log files that are in /tmp? Also, can you add the contents of /proc/cmdline? This error should only be fatal if anaconda is being run in debug mode, so if you have a way to remove inst.debug from the boot options, please try that
Comment 2 Steve Tyler 2013-09-04 14:49:29 EDT
If /tmp/anaconda-tb is present, that is the only one needed, because it contains all the other log files.

It should have /proc/cmdline.
Comment 3 Mark Langsdorf 2013-09-04 14:53:42 EDT
[anaconda root@calxeda-f20-v7hl pyanaconda]# cat /proc/cmdline 
ksdevice=bootif lang=  console=ttyAMA0,115200 earlyprintk locale=en_US text cpuidle.off=1 priority=critical ip=eth0:dhcp debug kssendmac inst.sshd  ks=http://swdev2.calxeda.com/fedora/kickstarts/f20-highbank.ks fixrtc vram=48M omapfb.vram=0:24M
[anaconda root@calxeda-f20-v7hl pyanaconda]# 

the only file I have in /tmp is /tmp/anaconda.log, as follows:
[anaconda root@calxeda-f20-v7hl pyanaconda]# cat /tmp/anaconda.log 
01:14:46,407 INFO anaconda: /sbin/anaconda 20.9-1
01:14:47,082 INFO anaconda: 4194304 kB (4096 MB) are available
01:14:47,082 INFO anaconda: check_memory(): total:4096, needed:512, graphical:512
01:14:47,101 INFO anaconda: anaconda called with cmdline = ['/sbin/anaconda']
01:14:47,103 INFO anaconda: Default encoding = utf-8 
01:14:48,188 WARN anaconda.stdout: Not asking for VNC because of an automated install
01:14:48,191 WARN anaconda.stdout: Not asking for VNC because text mode was explicitly asked for in kickstart
01:14:48,218 INFO anaconda: Display mode = t
01:14:48,223 INFO anaconda: 4194304 kB (4096 MB) are available
01:14:48,223 INFO anaconda: check_memory(): total:4096, needed:512, graphical:512
01:14:48,452 WARN anaconda: module import of __init__ failed: <type 'exceptions.AttributeError'>
[anaconda root@calxeda-f20-v7hl pyanaconda]# 

(it's faster for me to add them in comments than to scp them to somewhere I can upload them. The vram and omap stuff in the command line is added by our cobbler instance and can't easily be removed but it should also be ignored.)
Comment 4 Mark Langsdorf 2013-09-04 14:59:32 EDT
Okay, there was an errant debug option on the command line. Thanks!

Note You need to log in before you can comment on or make changes to this bug.