This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1004562 - Cannot connect to solidoodle 2 printer on /dev/ttyACM0
Cannot connect to solidoodle 2 printer on /dev/ttyACM0
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: RepetierHost (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-04 20:08 EDT by Tom Horsley
Modified: 2013-09-04 22:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-04 22:26:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom Horsley 2013-09-04 20:08:22 EDT
Description of problem:

I can't ever get the printer to connect. It works fine in pronterface, and if I copy the settings (/dev/ttyACM0, 115200 baud, etc) nothing happens in RepetierHost. The printer always shows as disconnected (yes, I've exited pronterface by now - no one else is using the tty port).


Version-Release number of selected component (if applicable):
RepetierHost-0.90C-1.fc19.noarch

How reproducible:
every time

Steps to Reproduce:
1.see above
2.
3.

Actual results:
no printer connection

Expected results:
connected and able to manually move the extruder around.

Additional info:
Comment 1 Tom Horsley 2013-09-04 20:09:28 EDT
I should add that the pronterface I'm using for comparison is the one downloaded from the solidoodle web site, not the one in the fedora repos.
Comment 2 Miro Hrončok 2013-09-04 20:21:15 EDT
(In reply to Tom Horsley from comment #1)
> I should add that the pronterface I'm using for comparison is the one
> downloaded from the solidoodle web site, not the one in the fedora repos.
Shouldn't make any difference.

My RepRap is currently disassembled (and will stay that way for at least a week), so cloud you help me a bit?

Is there any terminal output while failing to connect?

Please download the binaries from http://www.repetier.com/download/ and try connecting with them also.
Comment 3 Tom Horsley 2013-09-04 20:54:19 EDT
It gives no output at all, and in fact if I run it under strace, the only time /dev/ttyACM0 appears is in a stat() or lstat() call. There doesn't seem to be any attempt to actually open it.

Of course, I'm assuming it should automatically connect to the printer when I apply the settings, because I can't find anything like a "connect" button to push anywhere. If I've missed that, maybe that is why I never connect :-).
Comment 4 Tom Horsley 2013-09-04 21:11:19 EDT
And I just tried downloading the most recent 3 versions and running them which the same result. Nothing ever seems to try to open the tty device, which maybe means something is busted in mono?
Comment 5 Tom Horsley 2013-09-04 22:26:23 EDT
OK, false alarm. I really couldn't see the dadgum connect button. Once I found it and told it to actually connect to the solidoodle rather than the leftover "default" printer I actually can move the extruder around with manual control.

Note You need to log in before you can comment on or make changes to this bug.