This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1004757 - Changing "Group Shift/Lock behavior" breaks VT switching
Changing "Group Shift/Lock behavior" breaks VT switching
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 08:16 EDT by Michal Domonkos
Modified: 2014-06-16 06:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 06:42:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Domonkos 2013-09-05 08:16:37 EDT
Description of problem:
By default, when having multiple keyboard layouts configured, the key combo used to switch the layouts is "Both ALT keys pressed together". Changing this to another key combo (or even to nothing) breaks at least the standard CTRL+ALT+F* combo and thus prevents the user to switch to virtual terminals.

Quick testing also showed that setting the combo specifically to "Right ALT" or "Both ALT together" (the default) does not break VT switching.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg-1.1.1-48.100.el5

How reproducible:
always

Steps to Reproduce:
1. Preferences -> Keyboard
2. Add another layout on the Layout tab
3. On the Layout Options tab expand "Group Shift/Lock behavior", uncheck "Both Alt keys" and check e.g. "Alt+Shift"
4. Attempt to switch VT by pressing CTRL+ALT+F1

Actual results:
Nothing happens.

Expected results:
VT should be displayed.

Additional info:
I think this bug might be related to the following one:
https://bugzilla.redhat.com/show_bug.cgi?id=993936
Comment 1 RHEL Product and Program Management 2014-02-24 19:12:49 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2014-03-07 08:38:41 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 3 Ondrej Vasik 2014-06-16 06:42:37 EDT
Closing WONTFIX, as this doesn't sound as a blocker in production phase 3 and was not escalated.

Note You need to log in before you can comment on or make changes to this bug.