Bug 1004790 - Pulp 2.2 RPMs still install grinder
Pulp 2.2 RPMs still install grinder
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: rel-eng (Show other bugs)
2.2 Beta
Unspecified Unspecified
medium Severity unspecified
: ---
: 2.3.0
Assigned To: Barnaby Court
Preethi Thomas
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 09:42 EDT by Jay Dobies
Modified: 2013-12-09 09:31 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 09:31:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jay Dobies 2013-09-05 09:42:42 EDT
I may be wrong but I'm pretty sure grinder is no longer needed in 2.2. Below is the yum output from an install on a clean machine:

╭─[waterdeep]─[/etc/yum.repos.d]─[]─●
╰─➤ sudo yum install @pulp-server                                                     1 ↵
Plugin "pulp-profile-update" can't be imported
Loaded plugins: langpacks, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package pulp-puppet-plugins.noarch 0:2.2.0-0.32.beta.fc19 will be installed
--> Processing Dependency: python-pulp-puppet-common = 2.2.0 for package: pulp-puppet-plugins-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: python-pulp-common = 2.2.0 for package: pulp-puppet-plugins-2.2.0-0.32.beta.fc19.noarch
---> Package pulp-rpm-plugins.noarch 0:2.2.0-0.32.beta.fc19 will be installed
--> Processing Dependency: python-pulp-rpm-common = 2.2.0 for package: pulp-rpm-plugins-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: python-rhsm >= 1.8.0 for package: pulp-rpm-plugins-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: python-nectar >= 1.1.0 for package: pulp-rpm-plugins-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: grinder >= 0.1.16 for package: pulp-rpm-plugins-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: createrepo >= 0.9.9-21 for package: pulp-rpm-plugins-2.2.0-0.32.beta.fc19.noarch
---> Package pulp-selinux.noarch 0:2.2.0-0.32.beta.fc19 will be installed
---> Package pulp-server.noarch 0:2.2.0-0.32.beta.fc19 will be installed
--> Processing Dependency: python-okaara >= 1.0.32 for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: python-oauth2 >= 1.5.170-2.pulp for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: python-isodate >= 0.5.0-1.pulp for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: pymongo >= 2.1.1 for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: m2crypto >= 0.21.1.pulp-7 for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: python-webpy for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: mongodb-server for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: mongodb for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Processing Dependency: mod_ssl for package: pulp-server-2.2.0-0.32.beta.fc19.noarch
--> Running transaction check
---> Package createrepo.noarch 0:0.9.9-21.2.pulp.fc19 will be installed
--> Processing Dependency: python-deltarpm for package: createrepo-0.9.9-21.2.pulp.fc19.noarch
---> Package grinder.noarch 0:0.1.16-1.fc19 will be installed
---> Package m2crypto.x86_64 0:0.21.1-11.fc19 will be updated
---> Package m2crypto.x86_64 0:0.21.1.pulp-8.fc19 will be an update
---> Package mod_ssl.x86_64 1:2.4.6-2.fc19 will be installed
---> Package mongodb.x86_64 0:2.2.6-1.fc19 will be installed
--> Processing Dependency: libmongodb = 2.2.6-1.fc19 for package: mongodb-2.2.6-1.fc19.x86_64
--> Processing Dependency: libtcmalloc.so.4()(64bit) for package: mongodb-2.2.6-1.fc19.x86_64
---> Package mongodb-server.x86_64 0:2.2.6-1.fc19 will be installed
---> Package python-isodate.noarch 0:0.5.0-1.pulp.fc19 will be installed
---> Package python-nectar.noarch 0:1.1.1-1.fc19 will be installed
---> Package python-oauth2.noarch 0:1.5.211-4.fc19 will be installed
---> Package python-okaara.noarch 0:1.0.32-1.fc19 will be installed
---> Package python-pulp-common.noarch 0:2.2.0-0.32.beta.fc19 will be installed
---> Package python-pulp-puppet-common.noarch 0:2.2.0-0.32.beta.fc19 will be installed
---> Package python-pulp-rpm-common.noarch 0:2.2.0-0.32.beta.fc19 will be installed
---> Package python-pymongo.x86_64 0:2.5.2-1.fc19 will be installed
--> Processing Dependency: python-bson = 2.5.2-1.fc19 for package: python-pymongo-2.5.2-1.fc19.x86_64
---> Package python-rhsm.x86_64 0:1.10.1-1.fc19 will be installed
---> Package python-webpy.noarch 0:0.37-3.fc19 will be installed
--> Running transaction check
---> Package gperftools-libs.x86_64 0:2.1-1.fc19 will be installed
---> Package libmongodb.x86_64 0:2.2.6-1.fc19 will be installed
---> Package python-bson.x86_64 0:2.5.2-1.fc19 will be installed
---> Package python-deltarpm.x86_64 0:3.6-1.fc19 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==========================================================================================
 Package                       Arch       Version                  Repository        Size
==========================================================================================
Installing:
 pulp-puppet-plugins           noarch     2.2.0-0.32.beta.fc19     pulp-v2-beta      57 k
 pulp-rpm-plugins              noarch     2.2.0-0.32.beta.fc19     pulp-v2-beta     234 k
 pulp-selinux                  noarch     2.2.0-0.32.beta.fc19     pulp-v2-beta      40 k
 pulp-server                   noarch     2.2.0-0.32.beta.fc19     pulp-v2-beta     540 k
Updating:
 m2crypto                      x86_64     0.21.1.pulp-8.fc19       pulp-v2-beta     467 k
Installing for dependencies:
 createrepo                    noarch     0.9.9-21.2.pulp.fc19     pulp-v2-beta      90 k
 gperftools-libs               x86_64     2.1-1.fc19               updates          267 k
 grinder                       noarch     0.1.16-1.fc19            pulp-v2-beta     147 k
 libmongodb                    x86_64     2.2.6-1.fc19             updates          441 k
 mod_ssl                       x86_64     1:2.4.6-2.fc19           updates           95 k
 mongodb                       x86_64     2.2.6-1.fc19             updates           23 M
 mongodb-server                x86_64     2.2.6-1.fc19             updates          3.3 M
 python-bson                   x86_64     2.5.2-1.fc19             updates          110 k
 python-deltarpm               x86_64     3.6-1.fc19               updates           31 k
 python-isodate                noarch     0.5.0-1.pulp.fc19        pulp-v2-beta      46 k
 python-nectar                 noarch     1.1.1-1.fc19             pulp-v2-beta      43 k
 python-oauth2                 noarch     1.5.211-4.fc19           fedora            27 k
 python-okaara                 noarch     1.0.32-1.fc19            pulp-v2-beta      74 k
 python-pulp-common            noarch     2.2.0-0.32.beta.fc19     pulp-v2-beta      70 k
 python-pulp-puppet-common     noarch     2.2.0-0.32.beta.fc19     pulp-v2-beta      24 k
 python-pulp-rpm-common        noarch     2.2.0-0.32.beta.fc19     pulp-v2-beta      52 k
 python-pymongo                x86_64     2.5.2-1.fc19             updates          199 k
 python-rhsm                   x86_64     1.10.1-1.fc19            updates           99 k
 python-webpy                  noarch     0.37-3.fc19              fedora           141 k

Transaction Summary
==========================================================================================
Install  4 Packages (+19 Dependent packages)
Upgrade  1 Package

Total download size: 30 M
Is this ok [y/d/N]: N


Description: 

Packages to be added: 

Comps group:  

Default: 

Mandatory: 

Visible: 

Multi-lib: 

Need to be present for arches:
Comment 1 Barnaby Court 2013-09-17 09:44:35 EDT
Pull Requests: 
- pulp: https://github.com/pulp/pulp/pull/616
- pulp_rpm: https://github.com/pulp/pulp_rpm/pull/336
Comment 2 Jeff Ortel 2013-09-26 11:36:35 EDT
build: 2.3.0-0.15.alpha
Comment 3 Preethi Thomas 2013-09-27 14:07:41 EDT
[root@pulp-v2-server ~]# rpm -qa pulp-server
pulp-server-2.3.0-0.16.alpha.el6.noarch
[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# 
[root@pulp-v2-server ~]# rpm -qa |grep grinder
[root@pulp-v2-server ~]#
Comment 4 Preethi Thomas 2013-12-09 09:31:22 EST
Pulp 2.3 released.

Note You need to log in before you can comment on or make changes to this bug.