Bug 1004811 - 3.0 -> 4.0 upgrade path for ThinLVM driver
3.0 -> 4.0 upgrade path for ThinLVM driver
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 4.0
Assigned To: Eric Harney
Giulio Fidente
storage
:
Depends On:
Blocks: 975606
  Show dependency treegraph
 
Reported: 2013-09-05 10:24 EDT by Eric Harney
Modified: 2016-04-26 19:37 EDT (History)
8 users (show)

See Also:
Fixed In Version: openstack-cinder-2013.2-0.11.rc1.el6ost
Doc Type: Release Note
Doc Text:
Block Storage configurations previously using the setting: volume_driver=cinder.volume.drivers.lvm.ThinLVMVolumeDriver Should migrate to settings: volume_driver=cinder.volume.drivers.lvm.LVMISCSIDriver lvm_type=lvm The ThinLVMVolumeDriver alias for the volume driver will be removed in a future release.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:23:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1231116 None None None Never
OpenStack gerrit 48336 None None None Never

  None (edit)
Description Eric Harney 2013-09-05 10:24:31 EDT
I believe the upgrade path for users of the ThinLVM volume driver is broken between 3.0 and 4.0 currently.  In Havana, ThinLVM moved from being a separate volume driver to an option for the LVM volume driver, and the ThinLVM driver was removed.

Using the simple MAPPING dict in the volume manager which usually handles upgrades like this will not be a sufficient fix.  Code is needed to load the LVM driver if ThinLVM is specified and force on the "lvm_type=thin" option.
Comment 3 Scott Lewis 2013-11-19 11:54:17 EST
Auto adding >= MODIFIED bugs to beta
Comment 5 Giulio Fidente 2013-12-03 11:01:27 EST
verified using openstack-cinder-2013.2-3.el6ost.noarch
Comment 8 Stephen Gordon 2013-12-10 15:20:12 EST
This should probably be noted in line in the upgrade procedure itself as well.
Comment 10 errata-xmlrpc 2013-12-19 19:23:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.