Bug 100483 - CUPS not supporting Networked Jet Direct printing?
CUPS not supporting Networked Jet Direct printing?
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-printer (Show other bugs)
9
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-22 16:44 EDT by ab
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 11:57:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ab 2003-07-22 16:44:55 EDT
Description of problem

LPRng allows test pages for Jet Direct printers, but the same settings under
CUPS do not seem to

Version-Release number of selected component:

redhat-config-printer-0.6.47

How reproducible:

100%, as far as I can tell.

Steps to Reproduce:
1. Configure jet direct printer under CUPS (ip, port)
2. print test page.  No test page appears.
3. change print system to LPRng
4. print test page.  Test page appears.

Summary:

CUPS-> jet direct test page fails
LPRng -> jet direct test page succeeds

Additional info:

Was originally perplexed, as a RH8 box on the network does jet direct printing
with no problem.  I am guessing that is because RH8 does not use CUPS by
default, but RH9 does?

Printer in question is a laserjet hp 4100.  I use the ljet4 driver with it.  The
generic "Postscript" driver didn't make a difference.
Comment 1 Tim Waugh 2003-07-23 04:28:19 EDT
First things first: apply the redhat-config-printer RHBA (you can use up2date).
 That fixes a whole load of bugs.

If the problem still happens, I'll need to see the output of 'printconf-tui
--Xexport'.
Comment 2 ab 2003-07-24 11:54:44 EDT
Not sure what "RHBA" stands for (I'm guessing "RH"=Red Hat, but not sure what
"BA" is).  Applied the updates, and now the problem is solved.  

I was hesitant to upgrade things on here since the kernel, etc. is optimized for
notebook hardware, but did it anyway, and the problem automagically went away. 
(funny how that works, huh?  updates are a Good Thing...  ;-)

Thanks for the suggestion, and sorry for bothering you!
Comment 3 Tim Waugh 2003-07-24 11:57:27 EDT
"Red Hat Bugfix Advisory".

Note You need to log in before you can comment on or make changes to this bug.