Bug 1004859 - NPE when trying to run a VM with attached direct LUN
NPE when trying to run a VM with attached direct LUN
Status: CLOSED DUPLICATE of bug 1005572
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.3.0
Assigned To: Daniel Erez
Katarzyna Jachim
storage
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 11:42 EDT by Katarzyna Jachim
Modified: 2016-02-10 14:45 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-25 01:18:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test logs (vdsm, engine, server etc.) (2.49 MB, application/x-bzip2)
2013-09-05 11:42 EDT, Katarzyna Jachim
no flags Details

  None (edit)
Description Katarzyna Jachim 2013-09-05 11:42:49 EDT
Created attachment 794324 [details]
test logs (vdsm, engine, server etc.)

Description of problem:

After attaching a direct LUN to a VM I am unable to start it, startVM fails with following error in engine.log

2013-09-05 04:13:30,323 ERROR [org.ovirt.engine.core.bll.RunVmOnceCommand] (ajp-/127.0.0.1:8702-7) Command org.ovirt.engine.core.bll.RunVmOnceCommand throw exception: java.lang.NullPointerException
	at org.ovirt.engine.core.bll.storage.ISCSIStorageHelper.runConnectionStorageToDomain(ISCSIStorageHelper.java:68) [bll.jar:]
	at org.ovirt.engine.core.bll.storage.ISCSIStorageHelper.connectStorageToLunByVdsId(ISCSIStorageHelper.java:218) [bll.jar:]
	at org.ovirt.engine.core.bll.RunVmCommandBase.connectLunDisks(RunVmCommandBase.java:268) [bll.jar:]
	at org.ovirt.engine.core.bll.RunVmCommand.runVm(RunVmCommand.java:226) [bll.jar:]
	at org.ovirt.engine.core.bll.RunVmCommand.executeVmCommand(RunVmCommand.java:297) [bll.jar:]
	at org.ovirt.engine.core.bll.VmCommand.executeCommand(VmCommand.java:85) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.executeWithoutTransaction(CommandBase.java:1131) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.executeActionInTransactionScope(CommandBase.java:1216) [bll.jar:]
	at org.ovirt.engine.core.bll.CommandBase.runInTransaction(CommandBase.java:1881) [bll.jar:]
	at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInSuppressed(TransactionSupport.java:174) [utils.jar:]
	at org.ovirt.engine.core.utils.transaction.TransactionSupport.executeInScope(TransactionSupport.java:116) [utils.jar:]
...

Version-Release number of selected component (if applicable): is13


How reproducible: 100%
http://jenkins.qa.lab.tlv.redhat.com:8080/view/Storage/view/3.3/job/3.3-storage_direct_lun_sanity-iscsi-rest/85/

Steps to Reproduce:
1. create a VM, install OS
2. stop the VM
3. attach a direct LUN
4. start the VM

Actual results: action fails with java.lang.NullPointerException in engine.log

Expected results: action should succeed

Additional info:
Comment 1 Ayal Baron 2013-09-23 07:44:19 EDT
Daniel, is this a dup of a bug you've already solved?
Comment 2 Daniel Erez 2013-09-23 08:22:11 EDT
(In reply to Ayal Baron from comment #1)
> Daniel, is this a dup of a bug you've already solved?

Yes, it's a duplicate of bug 1005572 which is already ON_QA.
Comment 4 Sean Cohen 2013-09-25 01:18:30 EDT
Closing as duplicate of bug 1005572

*** This bug has been marked as a duplicate of bug 1005572 ***

Note You need to log in before you can comment on or make changes to this bug.