Bug 1004921 - SELinux is preventing /usr/lib/systemd/systemd-hostnamed from 'getattr' accesses on the file /proc/cpuinfo.
SELinux is preventing /usr/lib/systemd/systemd-hostnamed from 'getattr' acces...
Status: CLOSED DUPLICATE of bug 1000665
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ff6815a9338e9389d16c03ec1fd...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 14:20 EDT by menzinoah
Modified: 2013-09-09 14:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 14:49:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description menzinoah 2013-09-05 14:20:56 EDT
Description of problem:
SELinux is preventing /usr/lib/systemd/systemd-hostnamed from 'getattr' accesses on the file /proc/cpuinfo.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that systemd-hostnamed should be allowed getattr access on the cpuinfo file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-hostnam /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_hostnamed_t:s0
Target Context                system_u:object_r:proc_t:s0
Target Objects                /proc/cpuinfo [ file ]
Source                        systemd-hostnam
Source Path                   /usr/lib/systemd/systemd-hostnamed
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           systemd-204-9.fc19.x86_64
                              systemd-206-9.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-74.1.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.10-200.fc19.x86_64 #1 SMP Thu
                              Aug 29 19:05:45 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-09-05 20:19:35 CEST
Last Seen                     2013-09-05 20:19:35 CEST
Local ID                      1e8f0661-ee61-4516-a56f-f080d68f8e48

Raw Audit Messages
type=AVC msg=audit(1378405175.904:498): avc:  denied  { getattr } for  pid=4586 comm="systemd-hostnam" path="/proc/cpuinfo" dev="proc" ino=4026532023 scontext=system_u:system_r:systemd_hostnamed_t:s0 tcontext=system_u:object_r:proc_t:s0 tclass=file


type=SYSCALL msg=audit(1378405175.904:498): arch=x86_64 syscall=fstat success=yes exit=0 a0=5 a1=7fffad2eee10 a2=7fffad2eee10 a3=0 items=0 ppid=1 pid=4586 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=systemd-hostnam exe=/usr/lib/systemd/systemd-hostnamed subj=system_u:system_r:systemd_hostnamed_t:s0 key=(null)

Hash: systemd-hostnam,systemd_hostnamed_t,proc_t,file,getattr

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.10-200.fc19.x86_64
type:           libreport

Potential duplicate: bug 1000665
Comment 1 Miroslav Grepl 2013-09-09 14:49:29 EDT

*** This bug has been marked as a duplicate of bug 1000665 ***

Note You need to log in before you can comment on or make changes to this bug.