Bug 1004933 - Spice Audio has many pauses
Spice Audio has many pauses
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-server (Show other bugs)
6.5
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 15:18 EDT by Vimal Patel
Modified: 2013-09-30 09:58 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-30 09:58:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vimal Patel 2013-09-05 15:18:39 EDT
Description of problem:
When playing audio from a spice guest, there are many pauses while playing an audio stream. (playing a .wav file).  This is not seen when testing in 6.4.
This has been caught by our automated testing.
Reports show between 10-15 pauses while playing audio for 200seconds in 6.5:
14:26:13 ERROR| 10 pauses detected:
14:26:13 INFO | start:   2.498639s     duration:   0.114802s
14:26:13 INFO | start:  23.423288s     duration:   0.094484s
14:26:13 INFO | start:  39.195556s     duration:   0.089337s
14:26:13 INFO | start:  75.749932s     duration:   0.085096s
14:26:13 INFO | start:  86.206236s     duration:   0.093668s
14:26:13 INFO | start: 112.325760s     duration:   0.086548s
14:26:13 INFO | start: 143.670136s     duration:   0.093282s
14:26:13 INFO | start: 154.104921s     duration:   0.104053s
14:26:13 INFO | start: 175.021927s     duration:   0.085323s
14:26:13 INFO | start: 190.663923s     duration:   0.107115s

In 6.4 there are 0-2 pauses seen while playing audio for 200 seconds.

*The test uses 6.5 alpha as host, client, and guest.
*This occurs regardless of the value of playback-compression (on & off)

Version-Release number of selected component (if applicable):
Host:
spice-vdagent-0.14.0-1.el6.x86_64
spice-server-0.12.4-3.el6.x86_64
spice-usb-share-4.9-9.el6.x86_64
spice-glib-0.20-7.el6.x86_64
autotest-beaker-spice-install_autotest-1.0-31.noarch
spice-gtk-0.20-7.el6.x86_64
spice-server-debuginfo-0.12.4-3.el6.x86_64
spice-gtk-python-0.20-7.el6.x86_64
libvirt-0.10.2-23.el6.x86_64

Client:
virt-viewer-0.5.6-7.el6.x86_64
spice-xpi-2.7-24.el6.x86_64
spice-glib-0.20-7.el6.x86_64
spice-gtk-0.20-7.el6.x86_64

Guest:
spice-vdagent-0.14.0-1.el6.x86_64

/usr/libexec/qemu-kvm -S -name vm1 -M pc -nodefaults -vga qxl -device driver=intel-hda -device driver=hda-duplex -chardev socket,id=hmp_id_hmp1,path=/tmp/monitor-hmp1-20130905-140436-RBRxW82h,server,nowait -mon chardev=hmp_id_hmp1,mode=readline -chardev socket,id=serial_id_serial1,path=/tmp/serial-serial1-20130905-140436-RBRxW82h,server,nowait -device isa-serial,chardev=serial_id_serial1 -device driver=virtio-serial-pci,id=virtio_serial_pci0 -chardev spicevmc,id=devvdagent,name=vdagent -device virtserialport,chardev=devvdagent,name=com.redhat.spice.0,id=vdagent,bus=virtio_serial_pci0.0 -chardev socket,id=seabioslog_id_20130905-140436-RBRxW82h,path=/tmp/seabios-20130905-140436-RBRxW82h,server,nowait -device isa-debugcon,chardev=seabioslog_id_20130905-140436-RBRxW82h,iobase=0x402 -device driver=ich9-usb-uhci1,id=usb1 -drive file=/mnt/tests/spice/install_autotest/SpiceAutotestSetup/autotest/client/tests/virt/shared/data/images/rhel6devel-64.qcow2,if=none,id=drive-ide0-0-0,media=disk,cache=none,format=qcow2,aio=native -device driver=ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -device driver=e1000,mac=9a:8f:90:91:92:93,id=idP5fjso,netdev=idbiJh5q -netdev tap,id=idbiJh5q,fd=18 -m 1024 -smp 1,maxcpus=1,cores=1,threads=1,sockets=1 -cpu Conroe -device usb-tablet,id=usb-tablet1,bus=usb1.0,port=1 -spice port=3000,disable-ticketing,seamless-migration=on,image-compression=auto_glz,jpeg-wan-compression=auto,zlib-glz-wan-compression=auto,streaming-video=filter,playback-compression=on -rtc base=utc,clock=host,driftfix=none -boot order=cdn,once=c,menu=off -enable-kvm


How reproducible:
100%

Steps to Reproduce:
1. play an audio stream (pauses can be heard)
2.
3.

Actual results:
pauses in playing audio streams

Expected results:
no pauses

Additional info:
Comment 3 Yonit Halperin 2013-09-10 10:53:23 EDT
Can you explain/attach the script you use to identify pauses? What audio file do you use? Which guest application do you use to play the file?
Comment 4 Vimal Patel 2013-09-10 13:30:03 EDT
The script that I used is an autotest script:
https://github.com/spiceqa/virt-test/blob/final/tests/rv_audio.py

It's not necessary to use the script, when testing it manually I was able to hear the pauses in the audio stream, which does not happen in RHEL 6.4.

Both the automated test, and when I tested it manually aplay was used to play the audio file.

The audio file was too large to attach to the bug, I can send it to you directly.
or you can find it in our git:
If you do a git clone of:
git+ssh://code.engineering.redhat.com/autotest-beaker.git

The file tone.wav can be found under the autotest-beaker/install_autotest/ directory.
Comment 5 Yonit Halperin 2013-09-11 10:28:40 EDT
Hi, I don't manage to reproduce it. I don't notice any significant pauses. Did you test it manually on a non autotest environment (e.g., not in an embedded vm)? Does it happen only with spice?

(In reply to Vimal Patel from comment #4)
> The script that I used is an autotest script:
> https://github.com/spiceqa/virt-test/blob/final/tests/rv_audio.py
> 
> It's not necessary to use the script, when testing it manually I was able to
> hear the pauses in the audio stream, which does not happen in RHEL 6.4.
> 
> Both the automated test, and when I tested it manually aplay was used to
> play the audio file.
> 
> The audio file was too large to attach to the bug, I can send it to you
> directly.
> or you can find it in our git:
> If you do a git clone of:
> git+ssh://code.engineering.redhat.com/autotest-beaker.git
> 
> The file tone.wav can be found under the autotest-beaker/install_autotest/
> directory.
Comment 6 Vimal Patel 2013-09-18 10:22:23 EDT
I tried this again with a 6.5 beta host, client, and guest, and I was unable to reproduce the pauses in playing audio.

Note You need to log in before you can comment on or make changes to this bug.