Bug 1004935 - InstallSummary.html included in ER2 build results in errors the first time the server is started
InstallSummary.html included in ER2 build results in errors the first time th...
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Build Process (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Julian Coleman
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 15:22 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-05 15:28:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Len DiMaggio 2013-09-05 15:22:34 EDT
Description of problem:

The InstallSummary.html file included in the ER2 build contains this definition:

<div class="body">/home/rnc/SOA-6.1.0</div><h1>Administrative User</h1>

As a result, errors such as these are written to stderr (these are not written to the server.log) the first time the server is started:

Caused by: java.io.FileNotFoundException: /home/rnc/SOA-6.1.0/jboss-eap-6.1/standalone/log/server.log (No such file or directory)

Version-Release number of selected component (if applicable):
6.0.ER2

How reproducible:
Start the server.

Steps to Reproduce:
1. unzip soa-6.0.0.ER2-redhat-1.zip
2. cd bin
3. sh ./standalone.sh

Actual results:

[ldimaggi@ldimaggi bin]$ sh ./standalone.sh 
=========================================================================

  JBoss Bootstrap Environment

  JBOSS_HOME: /opt/local/SOA_servers/SOA6/ER2_Sept5/SOA-6.1.0/jboss-eap-6.1

  JAVA: /usr/lib/jvm/jre-1.7.0-openjdk.x86_64//bin/java

  JAVA_OPTS:  -server -XX:+UseCompressedOops -Xms1303m -Xmx1303m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true

=========================================================================

java.lang.IllegalArgumentException: Failed to instantiate class "org.jboss.logmanager.handlers.PeriodicRotatingFileHandler" for handler "FILE"
	at org.jboss.logmanager.config.AbstractPropertyConfiguration$ConstructAction.validate(AbstractPropertyConfiguration.java:118)
	at org.jboss.logmanager.config.LogContextConfigurationImpl.doPrepare(LogContextConfigurationImpl.java:333)
	at org.jboss.logmanager.config.LogContextConfigurationImpl.prepare(LogContextConfigurationImpl.java:290)
	at org.jboss.logmanager.config.LogContextConfigurationImpl.commit(LogContextConfigurationImpl.java:299)
	at org.jboss.logmanager.PropertyConfigurator.configure(PropertyConfigurator.java:505)
	at org.jboss.logmanager.PropertyConfigurator.configure(PropertyConfigurator.java:96)
	at org.jboss.as.logging.logmanager.ConfigurationPersistence.configure(ConfigurationPersistence.java:128)
	at org.jboss.logmanager.LogManager.readConfiguration(LogManager.java:300)
	at org.jboss.logmanager.LogManager.readConfiguration(LogManager.java:262)
	at java.util.logging.LogManager$2.run(LogManager.java:285)
	at java.util.logging.LogManager$2.run(LogManager.java:283)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.util.logging.LogManager.readPrimordialConfiguration(LogManager.java:283)
	at java.util.logging.LogManager.getLogManager(LogManager.java:265)
	at java.util.logging.Logger.<init>(Logger.java:258)
	at java.util.logging.Logger.<init>(Logger.java:254)
	at java.util.logging.LogManager$RootLogger.<init>(LogManager.java:1316)
	at java.util.logging.LogManager$RootLogger.<init>(LogManager.java:1314)
	at java.util.logging.LogManager$1.run(LogManager.java:196)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.util.logging.LogManager.<clinit>(LogManager.java:173)
	at org.jboss.modules.Main.main(Main.java:394)
Caused by: java.lang.reflect.InvocationTargetException
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:57)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:45)
	at java.lang.reflect.Constructor.newInstance(Constructor.java:526)
	at org.jboss.logmanager.config.AbstractPropertyConfiguration$ConstructAction.validate(AbstractPropertyConfiguration.java:116)
	... 21 more
Caused by: java.io.FileNotFoundException: /home/rnc/SOA-6.1.0/jboss-eap-6.1/standalone/log/server.log (No such file or directory)
	at java.io.FileOutputStream.open(Native Method)
	at java.io.FileOutputStream.<init>(FileOutputStream.java:212)
	at org.jboss.logmanager.handlers.FileHandler.setFile(FileHandler.java:154)
	at org.jboss.logmanager.handlers.PeriodicRotatingFileHandler.setFile(PeriodicRotatingFileHandler.java:105)
	at org.jboss.logmanager.handlers.FileHandler.setFileName(FileHandler.java:192)
	at org.jboss.logmanager.handlers.FileHandler.<init>(FileHandler.java:122)
	at org.jboss.logmanager.handlers.PeriodicRotatingFileHandler.<init>(PeriodicRotatingFileHandler.java:73)
	... 26 more

Expected results:
The server should start up cleanly.

Additional info:
See attached file.

Note You need to log in before you can comment on or make changes to this bug.