Bug 100496 - anaconda need all 3 iso while harddisk-inst
Summary: anaconda need all 3 iso while harddisk-inst
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: beta1
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-22 22:22 UTC by shrek-m
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-24 02:38:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description shrek-m 2003-07-22 22:22:57 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Netscape/7.1

Description of problem:
for an harddisk - installatin anaconda need all 3 iso

i need/will_do a quick minimal intstallation from harddisk
eg. ide-enclosure-usb, external scsi, usb-stick, ...
eg. testing if the hardware is supported, rescue-replacement-server/squid, ...

afaik
for an english-minimal-inst iso #1 is enough
for an german-minimal-inst iso #1 #2 are enough

i gave anaconda only iso #1 #2
the installation runs just fine at the point where the root-password is given,
afterwards anaconda recognize that there is no disc3 and give me only the
possibility for reboot  :-(


- why is there no testing long before this point ?
- why is there no query if it is ok that there is only iso #1 #2 ?
- why is there no possibility to change the media while installation
(usb/firewire) ?
- why is there no possibility to jump over some packages while installation when
something goes wrong ?

Version-Release number of selected component (if applicable):
severn beta1

How reproducible:
Always

Steps to Reproduce:
1. provide anaconda iso #1 #2
2. floppy boot 
3. harddisk installation
    

Actual Results:  installation brakes after rootpassword-query because there is
no iso #3

Expected Results:  - iso-check while choosing the partition/directory
- query if it is ok that there is no iso #3
- the possibility to jump over the warning/error without reboot

Additional info:

Comment 1 Jeremy Katz 2003-07-24 02:38:20 UTC
We can't know how many CDs there are in the set until we read the header list
(which is late so that machines with lower ram can actually be partitioned and
turn on swap first).

There's another bug about being able to cut down packages based on available
ISOs.  It falls into the "someday" category.


Note You need to log in before you can comment on or make changes to this bug.