This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1005001 - F-19 install from dvd-r in HP ENVY H8-1520T results in hd which cannot boot either Fedora 19 or Windows 8
F-19 install from dvd-r in HP ENVY H8-1520T results in hd which cannot boot e...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
19
i386 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-05 22:14 EDT by jrbruce86
Modified: 2015-02-17 12:05 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 12:05:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (569.88 KB, text/plain)
2013-09-06 14:23 EDT, jrbruce86
no flags Details

  None (edit)
Description jrbruce86 2013-09-05 22:14:01 EDT
Description of problem:

Using legacy boot option of cd/dvd-r without secure boot or UEFI (on HP ENVY H8-1520T PC), I ran the installer for Fedora 19 (booting from a dvd-r). Secure boot was turned off because it would result int the install disk hanging with an error message I cannot recall at this moment. The legacy boot of the disk (rather than UEFI) was used because when I tried with the UEFI option the install disk would hang with the message "Secure boot disabled". Using the legacy dvd-r/cd option in bios allowed me to run the installer without any problems. For my 1 TB hard-drive I reclaimed most of the space from the Windows 8 partition (leaving about 80 GB for it), and automatically had this space put in the Fedora 19 /home parition. The install seemed to go smoothly. When I rebooted from the hard-disk I get a message indicating that no bootable medium was found on the hard-disk. This occurs both when I try to boot using the windows boot manager in UEFI and when I use the legacy hard disk option. 

Version-Release number of selected component (if applicable): Fedora 19 Anaconda Installer


How reproducible:


Steps to Reproduce:
1. Go into bios and disable secure boot option, enable booting from legacy cd/dvd-r, disable all UEFI boot options, and bring legacy cd/dvd-r option to the top of the list so it boots from there. 
2. Run the Fedora 19 installer from dvd-r, reclaiming whatever space from Windows 8 partition is necessary.
3. Reboot computer and update bios to load from the hard disk in either UEFI mode or legacy. Either way the same message regarding "No bootable medium found" is displayed. All that can be done is to try booting with the installer to continue debugging.

Actual results:
Black screen with a brief message similar to "No bootable medium found" is displayed.

Expected results:
I'm expecting to see the grub2 bootloader but it is not being brought up for some reason.

Additional info:
Comment 1 jrbruce86 2013-09-06 14:23:29 EDT
Created attachment 915762 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 2 jrbruce86 2013-09-06 14:55:07 EDT
Sorry for not using an attachment above ^ :/...

UPDATE:
When I checked my partitions with gparted I found that /dev/sda1 is corrupted somehow.
Comment 3 jrbruce86 2013-09-06 15:09:43 EDT
Here is how my hard disk looks:

(1) sda1: unknown file system, 1 MB. flag says "bios_grub" 
(2) sda2: ext4, 500 MB. 
(3) unallocated, 1010 MB. 
(4) windows 8 os ntfs, 69.7 GB. 
(5) lvm2 pv, fedora, 860.3 GB.

Any recommendations are welcomed!!
Comment 4 jrbruce86 2013-09-06 15:30:36 EDT
When trying to reformat my hard disk using gparted so that it looks like

sda1: ext4, 1511MB
sda4: ntfs, windows 8 os, 69.7GB
sda3: lvm2 pv, fedora, 860.3 GB

I get the following error message:

Windows is hibernated, refused to mount. Failed to mount /dev/sda4: Operation not permitted. The NTFS partition is hibernated. Please resume Windows and turned it off properly, so mounting could be done safely.
Comment 5 jrbruce86 2013-09-06 16:43:06 EDT
When I finally gave up on windows 8 and instead did an entire fresh install, it worked. From this I have learned that the new UEFI settings in BIOS can be very tricky. A major issue could have been that I never properly shut down Windows 8 prior to running the install disc. The above error seems to suggest that Windows 8 was in some sort of hibernation mode, which seems odd to me since it I would assume it is impossible for the OS to be "hibernating" while I am in bios. If I could go back I would make sure the OS is shut down properly. 

Perhaps if the next release of Anaconda will check for such a condition this may prove beneficial. Those are my thoughts anyway. Any further thoughts or recommendations from anyone are welcome. This bug took two days away from me so I hope that something can be learned from it! Thanks in advance.
Comment 6 Fedora End Of Life 2015-01-09 14:44:57 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 7 Fedora End Of Life 2015-02-17 12:05:29 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.