Bug 1005030 - Unable to generate coredump.
Unable to generate coredump.
Status: CLOSED DUPLICATE of bug 1005031
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor (Show other bugs)
3.2.0
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Mike Burns
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 01:07 EDT by Pratik Pravin Bandarkar
Modified: 2013-09-06 01:14 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-06 01:14:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pratik Pravin Bandarkar 2013-09-06 01:07:27 EDT
Description of problem:
Customer did following configuration on RHEV-H:
---
1. Added "DAEMON_COREFILE_LIMIT=’unlimited’" line to /etc/sysconfig/init.

<snip>
[pbandark@pbandark 20-rhevh1-2013082619591377547158]$ grep -i DAEMON_COREFILE_LIMIT etc/sysconfig/init 
DAEMON_COREFILE_LIMIT='unlimited'
</snip>

# persist /etc/sysconfig/init

2. [root@rhevh1 admin]# cat /proc/sys/kernel/core_pattern
/var/log/core/core.%p.%t.dump

3. Rebooted the host.

<snip>
[root@rhevh1 admin]# ls -ldZ /var/log/
drwxr-xr-x. root root system_u:object_r:var_log_t:s0   /var/log/
[root@rhevh1 admin]# ls -ldZ /var/log/core/
drwxrwxrwt. root root system_u:object_r:var_log_t:s0   /var/log/core/
</snip>
---

but still after segfault in qemu-kvm process coredump is not getting generated at "/var/log/core/".


Version-Release number of selected component (if applicable):
$ cat etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 6.4 (20130709.0.el6_4)


How reproducible:
100%

Steps to Reproduce:
Similar to Description.

Actual results:
coredump is not getting generated.

Expected results:
Coredump file should gnerate if segfault in qemu process.

Additional info:
I tested on my test system. I observed same behaviour. Am i missing any step?
Comment 1 Itamar Heim 2013-09-06 01:14:47 EDT

*** This bug has been marked as a duplicate of bug 1005031 ***

Note You need to log in before you can comment on or make changes to this bug.