This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1005038 - Cannot probe new peer into upgraded cluster
Cannot probe new peer into upgraded cluster
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kaushal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 01:29 EDT by Kaushal
Modified: 2014-04-17 09:14 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-17 09:14:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushal 2013-09-06 01:29:01 EDT
A cluster which has been newly upgraded to 3.4 from a previous gluster version, cannot probe a new version 3.4 peer.
This happens because an upgraded cluster will retain its original op-version of 1, whereas the newly installed peer will start with op-version 2. In the current implementation, the op-version of a peer cannot be bumped down during probe/handshake, so the probe will fail in this case.
Comment 1 Anand Avati 2013-09-06 01:30:55 EDT
REVIEW: http://review.gluster.org/5715 (glusterd: Allow bumping down a peer's op-version during probe) posted (#2) for review on master by Kaushal M (kaushal@redhat.com)
Comment 2 Anand Avati 2013-09-06 06:14:48 EDT
REVIEW: http://review.gluster.org/5834 (glusterd: Allow bumping down a peer's op-version during probe) posted (#1) for review on release-3.4 by Kaushal M (kaushal@redhat.com)
Comment 3 Anand Avati 2013-09-10 05:24:57 EDT
REVIEW: http://review.gluster.org/5715 (glusterd: Allow bumping down a peer's op-version during probe) posted (#3) for review on master by Kaushal M (kaushal@redhat.com)
Comment 4 Anand Avati 2013-09-10 05:28:17 EDT
REVIEW: http://review.gluster.org/5834 (glusterd: Allow bumping down a peer's op-version during probe) posted (#2) for review on release-3.4 by Kaushal M (kaushal@redhat.com)
Comment 5 Anand Avati 2013-09-10 12:08:40 EDT
COMMIT: http://review.gluster.org/5715 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit c05cd5a392efb382fc726c55f507beeedc824b02
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Aug 28 17:16:03 2013 +0530

    glusterd: Allow bumping down a peer's op-version during probe
    
    Earlier, a peer running a higher op-version couldn't be probed into a
    cluster running at a lower op-version. This created issues when trying
    to expand an upgraded cluster. This patch changes this behaviour.
    
    The cluster no longer rejects a peer being probed if its op-version is
    higher than the cluster op-version. The peer will reduce its op-version
    if it doesn't have any volumes. If the peer contains volumes and needs
    to reduce its op-version, it fails the handshake and the probe fails.
    
    Change-Id: I12c6c873922799e1557b7184e956baea643d0dea
    BUG: 1005038
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/5715
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Anand Avati 2013-09-10 12:10:02 EDT
COMMIT: http://review.gluster.org/5834 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 8565d383a11d52b2db649f0c277d6f9ef1e87623
Author: Kaushal M <kaushal@redhat.com>
Date:   Wed Aug 28 17:16:03 2013 +0530

    glusterd: Allow bumping down a peer's op-version during probe
    
      Backport of http://review.gluster.org/5715
    
    Earlier, a peer running a higher op-version couldn't be probed into a
    cluster running at a lower op-version. This created issues when trying
    to expand an upgraded cluster. This patch changes this behaviour.
    
    The cluster no longer rejects a peer being probed if its op-version is
    higher than the cluster op-version. The peer will reduce its op-version
    if it doesn't have any volumes. If the peer contains volumes and needs
    to reduce its op-version, it fails the handshake and the probe fails.
    
    BUG: 1005038
    Change-Id: Iabe790a9f826a4ac63d379eeeba01efcfef01f4d
    Signed-off-by: Kaushal M <kaushal@redhat.com>
    Reviewed-on: http://review.gluster.org/5834
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 7 Niels de Vos 2014-04-17 09:14:23 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.4.3, please reopen this bug report.

glusterfs-3.4.3 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should already be or become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

The fix for this bug likely to be included in all future GlusterFS releases i.e. release > 3.4.3. In the same line the recent release i.e. glusterfs-3.5.0 [3] likely to have the fix. You can verify this by reading the comments in this bug report and checking for comments mentioning "committed in release-3.5".

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/5978
[2] http://news.gmane.org/gmane.comp.file-systems.gluster.user
[3] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137

Note You need to log in before you can comment on or make changes to this bug.