Bug 1005079 - [virtio-win][viostor]win8-32 could copy file to readonly data disk with viostor-68 driver
[virtio-win][viostor]win8-32 could copy file to readonly data disk with viost...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity urgent
: rc
: 7.0
Assigned To: Amnon Ilan
Virtualization Bugs
:
Depends On:
Blocks: 1288337
  Show dependency treegraph
 
Reported: 2013-09-06 04:00 EDT by guo jiang
Modified: 2017-08-16 01:56 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-16 01:55:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description guo jiang 2013-09-06 04:00:05 EDT
Description of problem:
win8-32 could copy file to readonly data disk.

Version-Release number of selected component (if applicable):
  kernel-2.6.32-416.el6.x86_64
  qemu-kvm-rhev-0.12.1.2-2.398.el6.x86_64
  virtio-win-prewhql-0.1.68
  spice-server-0.12.4-2.el6.x86_64  
  seabios-0.6.1.2-28.el6.x86_64
  vgabios-0.6b-3.7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.create disk1.qcow2 data disk image and assign 2G space

2.Boot guest with CLI(readonly=on for disk1.qcow2):
  /usr/libexec/qemu-kvm -M rhel6.5.0 -m 2G -smp 2,cores=2 -cpu SandyBridge -usb -device usb-tablet -enable-kvm -drive file=win8-32.qcow2,format=qcow2,if=none,id=drive-blk,cache=writeback,rerror=stop,werror=stop,serial=disk0 -device virtio-blk-pci,drive=drive-blk,id=blk0-0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=fe:23:40:21:22:31,id=net0 -uuid 8ff96365-d565-4304-8534-f1282aa90267 -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win8-32,server,nowait -mon chardev=111a,mode=readline -drive file=disk1.qcow2,format=qcow2,readonly=on,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -bios /usr/share/seabios/bios.bin -name win8-32 -vnc :2 -vga cirrus -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio 

3.Log in guest, online/initialize/format disk1

4.shutdown guest and boot with CLI(without readonly=on for disk1.qcow2)

5.Log in guest and online/initialize/format the disk1 and copy some files to disk1.

6.shutdown guest and boot with step2's CLI(with readonly=on for disk1.qcow2)

7.Log in guest and check the status of disk1 in "Disk Management",then copy file to disk1

8.In "Disk Management" click "rescan disks" and copy file to disk1

9.reboot guest and do step7

10.In "Disk Management" offline&online disk1. check the file you copied in step7 and copy new file to disk1.

Actual results:
step3, could online disk1, could not initialize and format it(disk1 readonly)
step5, could initialize and format it, could copy file to disk1
step7, the status is readonly, but could copy file to disk1
step8, after rescan, still could copy file to disk1
step9, the status is readonly, could copy file to disk1
step10, the file(we copied in step7)missing and could not copy file to disk1

Expected results:
step 7~10, the status in "Disk Management" is readonly and could not copy file to disk1. 

Additional info:
win7-64 no hit this issue.
Comment 3 Mike Cao 2014-03-17 04:46:41 EDT
lijin, pls help to check whether it can be reproduced in virtio-win-1.6.8-5
Comment 4 lijin 2014-03-17 05:30:31 EDT
(In reply to Mike Cao from comment #3)
> lijin, pls help to check whether it can be reproduced in virtio-win-1.6.8-5

with virtio-win-1.6.8-5.el7 and steps exactly same with comment #0,win8-32 guest still hit this issue.

Package info:
kernel-3.10.0-110.el7.x86_64
qemu-kvm-rhev-1.5.3-53.el7.x86_64
seabios-1.7.2.2-12.el7.x86_64
virtio-win-1.6.8-5.el7.noarch
Comment 6 Ronen Hod 2014-11-27 04:14:30 EST
Actually, this looks like an issue with both the Win driver and qemu.
Deferring
Comment 9 lijin 2015-03-31 01:49:29 EDT
still can hit similar issue with build 102

package info:
kernel-2.6.32-540.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.454.el6.x86_64
seabios-0.6.1.2-29.el6.x86_64
spice-server-0.12.4-12.el6.x86_64
virtio-win-prewhql-102

steps same as comment #0

actual result:
From step7 and step8,guest still CAN copy file to the readonly disk;
But different from comment #0,guest can NOT copy file to the readonly disk after reboot(step 9 and step 10)

Based on above ,this issue has NOT been fixed.
Comment 11 Peixiu Hou 2017-08-16 01:42:15 EDT
Tried to test this bug with virtio-win-prewhql-141, it cannot be reproduced now, guest can not copy file to the readonly disk.

package info:
kernel-3.10.0-691.el7.x86_64
qemu-kvm-rhev-2.9.0-14.el7.x86_64
seabios-1.10.2-3.el7.x86_64
virtio-win-prewhql-141

steps same as comment #0
Comment 12 lijin 2017-08-16 01:55:32 EDT
close this bug according to comment#11

Note You need to log in before you can comment on or make changes to this bug.