Bug 1005090 - F19 SDDM does not allow switching between desktops, i.e. KDE, GNOME
F19 SDDM does not allow switching between desktops, i.e. KDE, GNOME
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
19
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 04:12 EDT by Gerald Cox
Modified: 2013-09-09 13:27 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-09 13:27:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Cox 2013-09-06 04:12:12 EDT
Description of problem:
If you attempt to switch to another desktop after logoff from KDE, i.e. GNOME, SDDM sits with a blank screen with a cursor X for a few minutes, then you receive a message - "Unexpected error occurred, please logoff".  If you logoff, then select KDE PLASMA it works fine.  

The rendering of the photo for the userid is still poor.  Is this an issue with the system reducing the resolution when it is initially stored and then the size of the photo on SDDM is enlarged from a reduced resolution copy?  The original photo I used was of a sufficient resolution that it should be able to be displayed clearly.

Thanks!


Version-Release number of selected component (if applicable):
sddm-0.2.0-0.4.20130821gite707e229.fc19.x86_64

How reproducible:
After logoff from KDE, attempt to login to GNOME via SDDM

Steps to Reproduce:
1.  Logoff KDE
2.  Login GNOME
3.

Actual results:
Error message


Expected results:
Successful login to GNOME.  This functionality exists in KDM, LightDM and GDM - so I would expect it to also be available in SDDM.

Additional info:
Comment 1 Martin Bříza 2013-09-07 10:20:41 EDT
Hi Gerald,
thanks for your report. Could you please try to reproduce this with a stock configuration file? It's quite possible it wasn't replaced on update because SDDM is updating it every time it runs (a bug there, it' planned to be resolved soon).
Regarding the user pictures, I'll see what I can do.
Thanks,
Martin
Comment 2 Martin Bříza 2013-09-09 10:05:46 EDT
I tested this a few times on a two different machines and logging in and out of GNOME and KDE desktops in various order works just fine for me...
Comment 3 Gerald Cox 2013-09-09 13:27:06 EDT
Hey Martin...
I found that the problem occurs with gdm, lightdm and kdm... so I have some kind of Gnome issue, doesn't appear to be SDDM.  I also created a new userid just to make sure there wasn't anything in my home directory causing it.  Didn't make a difference. 

On the user pictures, if you can't improve the resolution might be better to just make them smaller.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.