Bug 1005091 - mismatch in systems count reported by dashboard for all orgs and by Splice report
mismatch in systems count reported by dashboard for all orgs and by Splice re...
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Splice Developers
Depends On:
  Show dependency treegraph
Reported: 2013-09-06 04:21 EDT by Jan Hutař
Modified: 2013-09-06 09:30 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-06 08:58:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-09-06 04:21:01 EDT
Description of problem:
There is a mismatch in systems count reported by dashboard for all orgs and by Splice report.

Version-Release number of selected component (if applicable):
SAM 1.3 snapshot #4

How reproducible:
always on mine installation

Steps to Reproduce:
1. Setup SAM with Splice and sync data from big Satellite 5.6.0 instalce
2. Compare sum of systems displayed for all synced organizations on Dashborad
   to count mentioned in Splice report (Administer -> Reports -> Red Hat
   Default Report -> Run Report)

Actual results:
Dashboards for:
  Org1: Total Systems:  359
  Org2: Total Systems:  206
  Org3: Total Systems:   13
  Org4: Total Systems: 1301
  Org5: Total Systems:    0
  Org6: Total Systems:    0
Enhanced Entitlement Report
  Subscribed Systems: 2500

Expected results:
Numbers should match.

Additional info:
Importing data into SAM might have been affected by bug 1004954 which happened and was reported before I have noted this.
Comment 2 Chris Duryee 2013-09-06 08:58:52 EDT
If you do a katello-configure to reset your db, you have to clear your mongodb as well. If you run the following, you should get correct data in the report:

 # mongo checkin-service
  > db.marketing_product_usage.drop()
  > exit
 # sudo su - splice -s /bin/bash
 $ spacewalk-splice-checkin --splice-sync 

Closing as notabug, but please re-open if the above doesn't fix the issue.
Comment 3 Chris Duryee 2013-09-06 09:30:05 EDT
Sorry, I misread your comment in 1004954.

What I believe happened is that you have duplicate entries due to #1004954. Running the same steps as above should clean them out.

Note You need to log in before you can comment on or make changes to this bug.