Bug 1005156 - dconf-editor crashes immediately after start
dconf-editor crashes immediately after start
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: dconf (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 06:25 EDT by Joachim Backes
Modified: 2013-09-28 09:49 EDT (History)
5 users (show)

See Also:
Fixed In Version: dconf-0.18.0-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-28 09:49:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dconf-editor strace (121.58 KB, text/plain)
2013-09-06 06:25 EDT, Joachim Backes
no flags Details
move schema compilation to editor subpackage (1.77 KB, patch)
2013-09-07 12:06 EDT, David King
no flags Details | Diff

  None (edit)
Description Joachim Backes 2013-09-06 06:25:05 EDT
Created attachment 794650 [details]
dconf-editor strace

Description of problem:
Starting dconf-editor: imediately crashes:

(dconf-editor:15007): GLib-GIO-ERROR **: Settings schema 'ca.desrt.dconf-editor.Settings' is not installed

Trace/breakpoint trap (core dumped)


Version-Release number of selected component (if applicable):
dconf-editor-0.17.0-3.fc20.x86_64

How reproducible:
always

Steps to Reproduce:
1.dconf-editor
2.
3.

Actual results:
crash

Expected results:


Additional info:
Comment 1 Matthias Clasen 2013-09-06 09:13:18 EDT
What do any of the following say ?

rpm -ql dconf-editor | grep schema
echo $GSETTINGS_SCHEMA_DIR

Does it start working after running the following (as root) ?

glib-compile-schemas /usr/share/glib-2/schemas
Comment 2 Joachim Backes 2013-09-06 11:14:27 EDT
(In reply to Matthias Clasen from comment #1)
> What do any of the following say ?
> 
> rpm -ql dconf-editor | grep schema
rpm -ql dconf-editor | grep schema
/usr/share/glib-2.0/schemas/ca.desrt.dconf-editor.gschema.xml


> echo $GSETTINGS_SCHEMA_DIR

empty string!!

> 
> Does it start working after running the following (as root) ?
> 
> glib-compile-schemas /usr/share/glib-2/schemas

glib-compile-schemas /usr/share/glib-2/schemas
Error opening directory '/usr/share/glib-2/schemas': No such file or directory
Comment 3 David King 2013-09-07 12:06:33 EDT
Created attachment 795148 [details]
move schema compilation to editor subpackage

(In reply to Joachim Backes from comment #2)
> glib-compile-schemas /usr/share/glib-2/schemas
> Error opening directory '/usr/share/glib-2/schemas': No such file or
> directory

Rather than "glib-2", the directory is actually "glib-2.0". After I do:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

dconf-editor starts fine. Looking at the .spec file:

http://pkgs.fedoraproject.org/cgit/dconf.git/tree/dconf.spec#n64

shouldn't the -editor package call glib-compile-schemas? I just installed dconf-editor on a fresh F20 system (where dconf was, of course, already installed), which did not compile the GSettings schemas, even though a new schema was installed. It looks like this broke in 0.16.0-2.

Attached is a patch which moves the schema compilation to the subpackage. I did a scratch build in Koji which seemed to work fine (both removal and installation updated the compiled schemas):

http://koji.fedoraproject.org/koji/taskinfo?taskID=5908023
Comment 4 Joachim Backes 2013-09-08 01:45:33 EDT
(In reply to David King from comment #3)
> Created attachment 795148 [details]
> move schema compilation to editor subpackage
> 
> (In reply to Joachim Backes from comment #2)
> > glib-compile-schemas /usr/share/glib-2/schemas
> > Error opening directory '/usr/share/glib-2/schemas': No such file or
> > directory
> 
> Rather than "glib-2", the directory is actually "glib-2.0". After I do:
> 
> sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Thank you. After this, dconf-editor runs perfectly!
Comment 5 Kalev Lember 2013-09-28 09:49:07 EDT
This got fixed in dconf-0.18.0-2.fc20.

Note You need to log in before you can comment on or make changes to this bug.