Bug 1005158 - Wrong summary on local folder
Wrong summary on local folder
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.5
All Linux
medium Severity medium
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 06:31 EDT by Jiri Koten
Modified: 2013-09-06 09:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-06 09:10:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri Koten 2013-09-06 06:31:17 EDT
Description of problem:
When I move some msgs from my imap account to an empty local folder, e.g Drafts in On This Computer, the folder summary gets stuck in showing unread msg count even if there are no unread msgs.

This problem seems to be related only to empty folders, also sometimes when I move msgs to local folders I got "Generating msg list" and no msgs are shown until I switch to different folder and back again.

Version-Release number of selected component (if applicable):
evolution-2.32.3-23.el6


How reproducible:
100%

Steps to Reproduce:
1. Move some msgs from your imap account to an empty local folder, i.e. On This Computer

Actual results:
Folder summary shows constantly unread msg count = msg count 

Expected results:
Folder summary is properly displayed. 

Additional info:
Comment 1 Milan Crha 2013-09-06 08:31:39 EDT
The "unread" count is treated differently on Outbox and Drafts folder, these always shows total count of messages in the folders. If you can reproduce on other than Drafts folder, then that might be a bug.
Comment 2 Jiri Koten 2013-09-06 09:10:27 EDT
I can confirm that the unread count is correct on other folders.

Note You need to log in before you can comment on or make changes to this bug.