Bug 1005159 - writes on cifs mount fails with "Bad file descriptor" when we perform changes to client graph
writes on cifs mount fails with "Bad file descriptor" when we perform changes...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: libgfapi (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Poornima G
Sudhir D
:
Depends On: 1004765
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 06:34 EDT by Poornima G
Modified: 2014-04-17 07:47 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1004765
Environment:
Last Closed: 2014-04-17 07:47:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-09-06 06:51:01 EDT
REVIEW: http://review.gluster.org/5837 (gfapi: store the open/create flags in fd_t object) posted (#1) for review on master by poornima g (pgurusid@redhat.com)
Comment 2 Anand Avati 2013-09-06 18:58:00 EDT
COMMIT: http://review.gluster.org/5837 committed in master by Anand Avati (avati@redhat.com) 
------
commit 1955f7dc84239f23660e23e637f9ddcc672cbeb7
Author: Poornima <pgurusid@redhat.com>
Date:   Fri Sep 6 16:13:30 2013 +0530

    gfapi: store the open/create flags in fd_t object
    
    The flags passed on to open and create calls were not being saved
    in the fd_t object, hence the fd migration was failing.
    
    Change-Id: I486bb818477fe4c393d64a711534a082162a0e53
    BUG: 1005159
    Signed-off-by: Poornima <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/5837
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Raghavendra Bhat <raghavendra@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 3 Anand Avati 2013-09-09 20:51:13 EDT
REVIEW: http://review.gluster.org/5873 (gfapi: store the open/create flags in fd_t object) posted (#1) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 4 Anand Avati 2013-09-09 21:05:39 EDT
REVIEW: http://review.gluster.org/5873 (gfapi: store the open/create flags in fd_t object) posted (#2) for review on release-3.4 by Anand Avati (avati@redhat.com)
Comment 5 Anand Avati 2013-09-10 04:16:13 EDT
COMMIT: http://review.gluster.org/5873 committed in release-3.4 by Vijay Bellur (vbellur@redhat.com) 
------
commit 49f073ec63d0ede22a390bf1ac33939dd65b6241
Author: Poornima <pgurusid@redhat.com>
Date:   Fri Sep 6 16:13:30 2013 +0530

    gfapi: store the open/create flags in fd_t object
    
    The flags passed on to open and create calls were not being saved
    in the fd_t object, hence the fd migration was failing.
    
    Change-Id: I486bb818477fe4c393d64a711534a082162a0e53
    BUG: 1005159
    Signed-off-by: Poornima <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/5873
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
Comment 6 Niels de Vos 2014-04-17 07:47:30 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.