This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1005180 - Anaconda fails to install on /dev/vda
Anaconda fails to install on /dev/vda
Status: CLOSED DUPLICATE of bug 1005154
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 07:30 EDT by Marian Csontos
Modified: 2013-09-10 09:52 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-10 09:52:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Csontos 2013-09-06 07:30:01 EDT
Description of problem:
Anaconda fails to install. Seems like it fails to recognize /dev/vda as installation target. I verified the device is present.

I am using virt-install, virtio disk and using kickstart in a VM.

Version-Release number of selected component (if applicable):
anaconda 19.31.14-1 (using latest RHEL7 nightly compose)

How reproducible:
100%

Steps to Reproduce:
When needed I will provide a more complete instructions.

Actual results:
Anaconda stops on the Report/Debug/Quit screen

Expected results:
Installation should proceed.

Additional info:

Kickstart disk options:

    ignoredisk --only-use=vda
    zerombr
    clearpart --all --initlabel --drives=vda
    autopart

Output:

    Generating updated storage configuration
    storage configuration failed: vda may not have enough space for grub2 to embed core.img when using the xfs filesystem on partition
    ================================================================================
    ================================================================================
    Installation
    
     1) [x] Installation source               2) [x] Timezone settings
            (http://download.eng.brq.redhat          (America/Chicago timezone)
            .com/pub/rhel/nightly/latest-RH   4) [x] Set root password
            EL-7/compose/Server/x86_64/os)           (Password is set.)
     3) [!] Install Destination               6) [x] Software selection
            (No disks selected)                      (Custom software selected)
     5) [x] Create user
            (No user will be created)
     7) [x] Network settings
            (Wired eth0 connected)
    
    ** (anaconda:778): WARNING **: Could not open X display
    An unknown error has occured, look at the /tmp/anaconda-tb* file(s) for more details
    
    ===============================================================================
    An unknown error has occurred
    ===============================================================================
    anaconda 19.31.14-1 exception report
    Traceback (most recent call first):
      File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/hubs/summary.py", line 60, in prompt
        raise RuntimeError(errtxt)
      File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 345, in _mainloop
        prompt = last_screen.prompt(self._screens[-1][1])
    RuntimeError: Can't have a question in command line mode!
    
    What do you want to do now?
    1) Report Bug
    2) Debug
    3) Quit
    
    Please make your choice from above: Something went wrong (tm)
    Cannot continue. Aborting.

I am failing to get any meaningful output out of it.
Comment 2 David Shea 2013-09-06 08:06:03 EDT
Can you attach the log files from /tmp after this occurs? Is there any existing data on /dev/vda?
Comment 3 Vratislav Podzimek 2013-09-10 09:52:38 EDT

*** This bug has been marked as a duplicate of bug 1005154 ***

Note You need to log in before you can comment on or make changes to this bug.