Bug 1005188 - Cannot show Guided Rule Editor source if rule uses CEPWindow
Cannot show Guided Rule Editor source if rule uses CEPWindow
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high
: ER4
: 6.0.0
Assigned To: manstis
Jiri Locker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 07:46 EDT by manstis
Modified: 2014-08-06 16:19 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description manstis 2013-09-06 07:46:27 EDT
Description of problem:

Rules using CEPWindows (length or time) lead to a RTE if user attempts to view source.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Create Type that has Role of Event
2. Create new guided rule using new Type
3. Use a CEP Window
4. Try to view source

Actual results:

RTE

Expected results:

Source displays correctly.

Additional info:
Comment 3 Jiri Locker 2013-09-16 04:56:35 EDT
Duplicate of bug 995455? Please close unless there is a reason for having a separate issue.
Comment 4 manstis 2013-09-20 03:35:25 EDT
It's not a duplicate; one relates to use of CEP operators (after, before etc) the other relates to use of CEP sliding windows (window:length, window:time).
Comment 8 Jiri Locker 2013-10-18 10:12:35 EDT
Fixed in ER4. Validation of a rule using CEP window fails but this should be fixed in bug 1005204.

Note You need to log in before you can comment on or make changes to this bug.