Bug 1005201 - zend app fails to start after jenkins build with hot_deploy marker
zend app fails to start after jenkins build with hot_deploy marker
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Vojtech Vitek
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 08:35 EDT by Oleg Fayans
Modified: 2016-11-30 19:27 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:49:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oleg Fayans 2013-09-06 08:35:15 EDT
Description of problem:
When I add a jenkins client to a zend app having the hot_deploy marker and then trigger jenkins build, the app fails to start

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a jenkins app
2. Create a zend app and add a hot_deploy marker to it
3. Add jenkins-client-1 cartridge to this app
4. Make some changes to the index.html of the app
5. git commit and push

Actual results:

The app stops and does not start automatically. Only starts if you do "rhc app start"

Expected results:

App does not stop, the build succeeds.

Additional info:

Reproduced on stg
Comment 1 Vojtech Vitek 2013-09-09 14:10:44 EDT
@ofayans I couldn't reproduce the issue with the following steps:

rhc app create jenkins jenkins
rhc app create zend zend-5.6 jenkins-client

cd zend
echo 1 > .openshift/markers/hot_deploy
git add .openshift/markers/hot_deploy
git commit -amhot
git push

echo 1 > php/index.php
git add php/index.php
git commit -amindex
git push

Am I missing anything? Can you please provide your full steps to reproduce?
Comment 2 Zhe Wang 2013-09-10 02:59:26 EDT
Hi, Vojtech,

I was able to reproduce this bug in devenv_3762 with the following steps:

1. create a Zend-5.6 app with a Jenkins-client added
rhc app create zendtst zend-5.6 --enable-jenkins

2. create a hot_deploy marker

3. push the change and trigger a Jenkins build

and the Jenkins log of this build is:

Stopping gear...
CLIENT_MESSAGE: Stopping Zend Server Console
Stopping Zend Server GUI [Lighttpd] [32m[OK][0m
CLIENT_MESSAGE: Stopping Zend Server JobQueue daemon
Stopping JobQueue [32m[OK][0m
CLIENT_MESSAGE: Stopping Apache
CLIENT_MESSAGE: Stopping Zend Server Monitor node
Stopping Zend Server Monitor node [32m[OK][0m
CLIENT_MESSAGE: Stopping Zend Server Deployment daemon
Stopping Deployment [32m[OK][0m
CLIENT_RESULT: Zend Server 5.6 stopped successfully
+ rsync --delete-after -azO -e /usr/libexec/openshift/cartridges/jenkins/bin/git_ssh_wrapper.sh /var/lib/openshift/522ebe2a4b224264aa000001/zend/phplib/ '522ebd624b22427d3f000211@zendtst-dev3761tst.dev.rhcloud.com:${OPENSHIFT_ZEND_DIR}phplib/'
+ rsync --delete-after -azO -e /usr/libexec/openshift/cartridges/jenkins/bin/git_ssh_wrapper.sh /var/lib/openshift/522ebe2a4b224264aa000001/app-root/runtime/repo/ '522ebd624b22427d3f000211@zendtst-dev3761tst.dev.rhcloud.com:${OPENSHIFT_REPO_DIR}'
+ /usr/libexec/openshift/cartridges/jenkins/bin/git_ssh_wrapper.sh 522ebd624b22427d3f000211@zendtst-dev3761tst.dev.rhcloud.com 'gear remotedeploy'
Starting application zendtst
Not starting cartridge jenkins-client because hot deploy is enabled
TODO
Not starting cartridge zend because hot deploy is enabled
Archiving artifacts

Looks like the deployment failed to detect the presence of the hot_deploy marker and actually stopped the app's gear. However, after the deployment, it could find the marker and failed to start the stopped gear.
Comment 3 Oleg Fayans 2013-09-10 03:22:13 EDT
Reproduced on devenv_3762

The steps are the following:
1. Create jenkins server
2. Create zend app
3. Add hot_deploy marker to the zend app
4. Add jenkins client to the zend app
5. Modify index.html, git commit && push

At this step the zend cartridge of the app stops and does not start automatically.
It should not stop at all
Comment 4 Vojtech Vitek 2013-09-11 13:47:19 EDT
https://github.com/openshift/li/pull/1894
Comment 5 Jhon Honce 2013-09-11 13:50:53 EDT
Fixed in https://github.com/openshift/li/pull/1894
Comment 6 Qiushui Zhang 2013-09-12 04:07:21 EDT
Tested on devenv_3776

Tried with the following steps:
1. Create jenkins app
2. Create zend app with jenkins-client
3. Add hot_deploy marker
4. Modify index.php
5. Git push the change

After the git push, I can visit the app web page successfully.

Mark the bug as verified.

Note You need to log in before you can comment on or make changes to this bug.