This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1005273 - RTGov client should be enhanced to notify on collection failures
RTGov client should be enhanced to notify on collection failures
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: RT Governance (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER3
: ---
Assigned To: Gary Brown
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 10:45 EDT by Len DiMaggio
Modified: 2015-08-02 19:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: ActivityLogger MBean has been enhanced to report a failure notification when it is unable to store activity information, as well as to provide an attribute representing the number of failures since the last successful attempt. Reason: To enable administrators to be informed when the runtime governance client is having problems reported activity information to the activity server. (Images from jconsole have been attached). Result (if any):
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attributes for ActivityLogger MBean (61.86 KB, image/png)
2013-09-09 11:15 EDT, Gary Brown
no flags Details
ActivityLogger notifications (63.76 KB, image/png)
2013-09-09 11:17 EDT, Gary Brown
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker RTGOV-269 Major Closed Report activity logger problems via MBean 2014-07-02 05:19:53 EDT

  None (edit)
Description Len DiMaggio 2013-09-06 10:45:29 EDT
Description of problem:

To provide for more reliability - in the event that the event collector crashes and events are lost, the RTGov client should be enhanced to notify (logging or MBean - TBD)

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 JBoss JIRA Server 2013-09-09 11:12:31 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-269 to Resolved
Comment 2 Gary Brown 2013-09-09 11:15:21 EDT
Created attachment 795661 [details]
Attributes for ActivityLogger MBean

This images shows the 'failures since last success' attribute which provides a count of the number of activity unit 'store' operations that have failed since the last activity information was successfully recorded. This information can be used to indicate whether the system is functioning correctly again.
Comment 3 Gary Brown 2013-09-09 11:17:42 EDT
Created attachment 795663 [details]
ActivityLogger notifications

ActivityLogger MBean generates notifications when it fails to store activity information.

To avoid the overhead of a notification being generated for each activity unit that fails to be recorded, the failure notification is only generated once every 5 minutes that the failure persists, as a reminder that there is still an issue to be resolved.
Comment 4 Jiri Pechanec 2013-09-23 23:44:46 EDT
Verified in ER3
Comment 8 JBoss JIRA Server 2014-07-02 05:19:54 EDT
Gary Brown <gary@brownuk.com> updated the status of jira RTGOV-269 to Closed

Note You need to log in before you can comment on or make changes to this bug.