Bug 1005379 - Performance test failure because of infinite loop issue when renaming a file
Performance test failure because of infinite loop issue when renaming a file
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gluster-swift (Show other bugs)
2.1
x86_64 Linux
urgent Severity urgent
: ---
: RHGS 2.1.0
Assigned To: Luis Pabón
Peter Portante
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 15:14 EDT by Luis Pabón
Modified: 2016-11-08 17:25 EST (History)
6 users (show)

See Also:
Fixed In Version: gluster-swift-plugin-1.8.0-7.el6rhs
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luis Pabón 2013-09-06 15:14:31 EDT
Description of problem:
From Peter Portante's Fix (http://review.gluster.org/5670) for gluster-swift master (Havana) branch:
    Fix infinite loop for temp file renames on ENOENT
    
    For whatever reason, it appears that GlusterFS, or perhaps FUSE can
    continuously return ENOENT on a rename system call even when we have
    double checked that there is no reason to do so. That is a bug for
    that sub system. However, our response to that bug can result in an
    infinite loop, which is bad.
    
    This code reduces that to 10 attempts.
    
    In addition, we restructed the open retry loop to match, providing
    module constants for the upper bounds of both retry loops.

Peter has been able to see this issue on his multiple node performance tests
for RHS 2.1.  The fix needs to be backported to upstream gluster-swift Grizzly
branch.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Luis Pabón 2013-09-06 15:22:11 EDT
Fix posted for review:  http://review.gluster.org/5848
Comment 6 Scott Haines 2013-09-23 18:32:34 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.