Bug 1005448 - RHEL6.5 ipa-replica-manage del unexpected error NoneType after upgrade from 6.2
RHEL6.5 ipa-replica-manage del unexpected error NoneType after upgrade from 6.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipa (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-06 23:53 EDT by Scott Poore
Modified: 2013-11-21 15:54 EST (History)
2 users (show)

See Also:
Fixed In Version: ipa-3.0.0-35.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 15:54:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log files (16.73 MB, application/x-tar)
2013-09-06 23:55 EDT, Scott Poore
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1651 normal SHIPPED_LIVE ipa bug fix and enhancement update 2013-11-20 19:39:40 EST

  None (edit)
Description Scott Poore 2013-09-06 23:53:50 EDT
Description of problem:

After upgrading from RHEL6.2 to 6.5, I am trying to delete a replica and I see this unexpected error:

Deleting replication agreements between rhel6-2.testrelm.com and rhel6-1.testrelm.com
ipa: INFO: Setting agreement cn=meTorhel6-1.testrelm.com,cn=replica,cn=dc\=testrelm\,dc\=com,cn=mapping tree,cn=config schedule to 2358-2359 0 to force synch
ipa: INFO: Deleting schedule 2358-2359 0 from agreement cn=meTorhel6-1.testrelm.com,cn=replica,cn=dc\=testrelm\,dc\=com,cn=mapping tree,cn=config
ipa: INFO: Replication Update in progress: FALSE: status: 0 Replica acquired successfully: Incremental update succeeded: start: 0: end: 0
Deleted replication agreement from 'rhel6-1.testrelm.com' to 'rhel6-2.testrelm.com'
unexpected error: %d format: a number is required, not NoneType
:: [   FAIL   ] :: Running 'ipa-replica-manage -p Secret123 del rhel6-2.testrelm.com -f' (Expected 0, got 1)


Version-Release number of selected component (if applicable):
ipa-server-3.0.0-34.el6.x86_64
389-ds-base-1.2.11.15-23.el6.x86_64


How reproducible:
Very (seems to be always at least in upgrade testing so far)

Steps to Reproduce:
1.  install IPA master and replica on 6.2
2.  Upgrade  both to 6.5 (3.0.0) version
3.  ipa-replica-manage -p Secret123 del <REPLICA> -f

Actual results:
unexpected error listed above

Expected results:
no error

Additional info:
Comment 1 Scott Poore 2013-09-06 23:55:52 EDT
Created attachment 795048 [details]
/var/log files
Comment 3 Martin Kosek 2013-09-09 04:02:43 EDT
This looks as a reproduction of upstream issue https://fedorahosted.org/freeipa/ticket/3876

Note that I was able to also reproduce with older IPA server:
ipa-server-3.0.0-26.el6_4.4.x86_64
389-ds-base-1.2.11.15-23.el6.x86_64

Definitely something we will want to have fixed in 6.5.
Comment 5 Martin Kosek 2013-09-09 09:35:32 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/3876
Comment 8 Scott Poore 2013-09-11 19:43:13 EDT
Verified.

Version ::

ipa-server-3.0.0-35.el6.x86_64


Automated Test Results ::

:: [   PASS   ] :: Running 'ipa-replica-manage -p Secret123 del ipaqa64vmb.testrelm.com -f > /tmp/tmpout.ipa_upgrade_uninstall_replica 2>&1' (Expected 0, got 0)
ipa: INFO: Setting agreement cn=meToipaqavma.testrelm.com,cn=replica,cn=dc\=testrelm\,dc\=com,cn=mapping tree,cn=config schedule to 2358-2359 0 to force synch
ipa: INFO: Deleting schedule 2358-2359 0 from agreement cn=meToipaqavma.testrelm.com,cn=replica,cn=dc\=testrelm\,dc\=com,cn=mapping tree,cn=config
ipa: INFO: Replication Update in progress: TRUE: status: 0 Replica acquired successfully: Incremental update started: start: 0: end: 0
ipa: INFO: Replication Update in progress: TRUE: status: 0 Replica acquired successfully: Incremental update started: start: 0: end: 0
ipa: INFO: Replication Update in progress: FALSE: status: 0 Replica acquired successfully: Incremental update succeeded: start: 0: end: 0
Deleting replication agreements between ipaqa64vmb.testrelm.com and ipaqavma.testrelm.com
Deleted replication agreement from 'ipaqavma.testrelm.com' to 'ipaqa64vmb.testrelm.com'
Background task created to clean replication data. This may take a while.
This may be safely interrupted with Ctrl+C
:: [   PASS   ] :: Running 'cat /tmp/tmpout.ipa_upgrade_uninstall_replica' (Expected 0, got 0)

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: ipa_upgrade_bz1005448 -  RHEL6.5 ipa-replica-manage del unexpected error NoneType after upgrade from 6.2
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

:: [   PASS   ] :: File '/tmp/tmpout.ipa_upgrade_uninstall_replica' should not contain 'unexpected error.*NoneType' 
:: [   PASS   ] :: BZ 1005448 not found
Comment 10 errata-xmlrpc 2013-11-21 15:54:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1651.html

Note You need to log in before you can comment on or make changes to this bug.