Bug 1005465 - quota: setting the soft/hard-timeout are reported in logs not on stdout
quota: setting the soft/hard-timeout are reported in logs not on stdout
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: Krutika Dhananjay
Saurabh
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 06:19 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.34rhs
Doc Type: Bug Fix
Doc Text:
Previously, quota options such as 'default-soft-limit', 'hard-timeout', 'soft-timeout' and 'alert-time' were not validated by glusterd. This resulted in invalid values in the brick volfile and restarting bricks failed due to validation failure of the option's value. Now with this update, glusterd validates the values and rejects any values falling out of range. It also reports the allowed range of values to the CLI.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:36:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport of a node (15.09 MB, application/x-xz)
2013-09-07 06:23 EDT, Saurabh
no flags Details

  None (edit)
Description Saurabh 2013-09-07 06:19:51 EDT
Description of problem:
response for setting soft/hard timeout should turn out to be an error for cli.

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.32rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. enable quota on a volume
2. set quota soft-timeout hard-timeout to 100hr
3.

Actual results:
the result is reported ad error in logs but the command it self is a pass.

[2013-09-07 10:10:16.370916] E [options.c:443:xlator_option_validate_time] 0-newvol-quota: '360000' in 'option soft-timeout 100hr' is out of range [0 - 1800]
[2013-09-07 10:10:16.372660] E [options.c:443:xlator_option_validate_time] 0-newvol-quota: '360000' in 'option soft-timeout 100hr' is out of range [0 - 1800]


Expected results:
the stdout should also send a response about the range and should not let such a big number to be set.

Additional info:
Comment 2 Saurabh 2013-09-07 06:23:29 EDT
Created attachment 795086 [details]
sosreport of a node
Comment 6 errata-xmlrpc 2013-11-27 10:36:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.