Bug 1005471 - Switch between English (India, Rupee Sign) and other Indic xkb layouts not working
Switch between English (India, Rupee Sign) and other Indic xkb layouts not wo...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 07:48 EDT by Omshivaprakash
Modified: 2013-10-10 06:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-10 06:19:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Omshivaprakash 2013-09-07 07:48:45 EDT
Description of problem:

While I use English (India, with Rupee Sign) keyabord layout with Kannada kn-itrans, Hindi itrans layout etc switching back to English doesn't work. I can only type english keys by holding alt key. 


Version-Release number of selected component (if applicable):

ibus = 1.5.3
gnome-shell - 3.8.4

How reproducible:

Steps to Reproduce:
1. Use English (India, with Rupee Sign) along any other m17n layout such as Kannada itrans
2.Switch to Kannada and try to switch back to english. 
3. Try to type something in editor or anywhere else you will see Kannada appearing.


Actual results:
Keyboard switch to en (with rupee symbol) shows Kannada (if kn-itrans used)

Expected results:

It should switch back to English

Additional info:
Comment 1 fujiwara 2013-09-08 21:58:34 EDT
I cannot reproduce your problem.
Why don't you use f19 instead of rawhide?
Did you install the latest ibus-m17n?

% rpm -q ibus-m17n
ibus-m17n-1.3.4-10.fc19.x86_64
Comment 2 Pravin Satpute 2013-09-10 03:04:48 EDT
Even i am not able to reproduce this issue. Its working fine with above mentioned rpm version.

Omshivaprakash are you able to type Rupee Symbol with AltGr+4?

I will test this with F20 TC5 and update more on this.
Comment 3 Omshivaprakash 2013-09-10 08:06:02 EDT
@Pravin Rupee Symbol works. I was also unable to reproduce this error on Fedora 19. 

I will check few more things and update this thread. 

Thanks
Comment 4 fujiwara 2013-10-10 00:03:28 EDT
Are you still able to reproduce your problem in f20 alpha or nightly?
Comment 5 Omshivaprakash 2013-10-10 06:19:55 EDT
Hi,

I'm unable to reproduce this error any more. This issue can be closed. 

Thanks
Shiv

Note You need to log in before you can comment on or make changes to this bug.