Bug 1005501 - Since update to kernel 3.10.5-201.fc19.x86_64, f19 doesn't boot or has no display
Since update to kernel 3.10.5-201.fc19.x86_64, f19 doesn't boot or has no dis...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 12:51 EDT by fred
Modified: 2013-11-17 02:43 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-17 02:43:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (2.55 KB, text/plain)
2013-09-07 12:51 EDT, fred
no flags Details
/var/log/messages with kernel 3.10.5 (121.54 KB, text/plain)
2013-09-07 12:56 EDT, fred
no flags Details
/var/log/messages (3.10.10) /var/log/Xorg.0.log /var/log/gdm (73.51 KB, application/x-gzip)
2013-09-08 04:22 EDT, fred
no flags Details
Last boot message before black screnn 1/2 (634.37 KB, image/png)
2013-09-08 15:45 EDT, fred
no flags Details
Last boot message before black screnn 2/2 (195.94 KB, image/png)
2013-09-08 15:45 EDT, fred
no flags Details
/var/log/messages, gdm and Xorg logs witk kernel 3.11.0-300 (98.92 KB, application/x-gzip)
2013-09-12 12:04 EDT, fred
no flags Details
/var/log/messages, gdm and Xorg logs witk kernel 3.11.0-300 (without rhgb quiet) (67.90 KB, application/x-gzip)
2013-09-15 03:29 EDT, fred
no flags Details

  None (edit)
Description fred 2013-09-07 12:51:28 EDT
Created attachment 795161 [details]
lspci

Description of problem:
Since update to kernel 3.10.5-201.fc19.x86_64, f19 doesn't boot or has no display.
It depends with the version of the kernel:
- With kernel 3.10.9: no display
- with kernel 3.10.10: boot stop after loading first services (screen stay black and no disk activity)
- with older version (3.10.5) it was only a display problem

Version-Release number of selected component (if applicable):
kernel 3.10.5-201.fc19.x86_64 to 3.10.10-200.fc19.x86_64

How reproducible:
update kernel with same devices (see attachment)

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 fred 2013-09-07 12:56:05 EDT
Created attachment 795162 [details]
/var/log/messages with kernel 3.10.5

I'm sure other information are nedded, but I don't know what.

When I write 'display problem, I mean 'No signal' on the screen.

Hope it can help.
Comment 2 Michele Baldessari 2013-09-07 15:47:00 EDT
Hi Fred,

can you remove the "quiet rhgb" options from the 3.10.10 kernel in /boot/grub2/grub.cfg and boot it and let me know what errors you get? Is just gdm failing to load or are there other specific issues?

Can you get both /var/log/messages in that case (just gdm failing), /var/log/Xorg.0.log and /var/log/gdm/*log

I see only "Aug  5 09:08:50 PCFD gdm-simple-slave[834]: WARNING: Failed to give slave programs access to the display. Trying to proceed." as potentially problematic.

hth,
Michele
Comment 3 fred 2013-09-08 04:22:12 EDT
Created attachment 795312 [details]
/var/log/messages (3.10.10) /var/log/Xorg.0.log /var/log/gdm
Comment 4 Michele Baldessari 2013-09-08 12:30:49 EDT
Hi,

I went through the logs but don't see anything of note. Do you see anything on the screen from gdm or does the screen stay black? Do you see the console messages?

Xorg seems to start correctly and recognizes your screen:
(II) RADEON(0): EDID vendor "HSD", prod id 35226

You say: - with older version (3.10.5) it was only a display problem

So kernels before 3.10.5 still had a display issue but 3.10.9 does not even boot?

thanks,
Michele
Comment 5 fred 2013-09-08 15:44:16 EDT
(In reply to Michele Baldessari from comment #4)
> Hi,
> 
> I went through the logs but don't see anything of note. Do you see anything
> on the screen from gdm or does the screen stay black? Do you see the console
> messages?
> 
> Xorg seems to start correctly and recognizes your screen:
> (II) RADEON(0): EDID vendor "HSD", prod id 35226
> 
> You say: - with older version (3.10.5) it was only a display problem
> 
> So kernels before 3.10.5 still had a display issue but 3.10.9 does not even
> boot?
> 
> thanks,
> Michele

Hello,

Thanks for helping me.

All was OK before kernel 3.10.5. The 3.10.4-300.fc19.x86_64 kernel is fine.

The problem "no disk activity" with kernel 3.10.10 was involved by a USB disk.

So the problem is only a display problem.
With kernel 3.10.9, the screen says "no signal"
With kernel 3.10.10, the screen stays black after starting some services.

I couldn't read what was written, so I've made a movie. I will attach the last images. The last service started is udev ("Started udev coldplug all devices") and the last line printed before the black screen is "fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver".

Best regards,
Fred
Comment 6 fred 2013-09-08 15:45:17 EDT
Created attachment 795392 [details]
Last boot message before black screnn 1/2
Comment 7 fred 2013-09-08 15:45:52 EDT
Created attachment 795393 [details]
Last boot message before black screnn 2/2
Comment 8 Michele Baldessari 2013-09-09 16:00:45 EDT
Hi Fred,

are you somehow able to start X somehow? (systemctl restart gdm or by launching startx from the console)

The regression is probably caused by one of the following commits:
$ git lg -i --grep radeon v3.10.4..v3.10.5
* 6655d76 - (2013-08-04 16:51:17 +0800)  radeon kms: do not flush uninitialized hotplug work <Sergey Senozhatsky>
* 6f8bbaf - (2013-08-04 16:51:14 +0800)  drm/radeon/atom: initialize more atom interpretor elements to 0 <Alex Deucher>
* 8414d40 - (2013-08-04 16:51:12 +0800)  drm/radeon: fix audio dto programming on DCE4+ <Alex Deucher>
* d54b22e - (2013-08-04 16:51:09 +0800)  drm/radeon: improve dac adjust heuristics for legacy pdac <Alex Deucher>
* 405a7cc - (2013-08-04 16:51:09 +0800)  drm/radeon: fix combios tables on older cards <Mark Kettenis>
* d19ccc4 - (2013-08-04 16:51:08 +0800)  drm/radeon: Another card with wrong primary dac adj <Ondrej Zary>
* f57cb1a - (2013-08-04 16:51:05 +0800)  drm/radeon: fix endian issues with DP handling (v3) <Alex Deucher>
* f92c99d - (2013-08-04 16:51:05 +0800)  drm/radeon: allow selection of alignment in the sub-allocator <Alex Deucher>
* c354867 - (2013-08-04 16:51:05 +0800)  drm/radeon: fix UVD fence emit <Christian König>
* 1b4eafa - (2013-08-04 16:51:03 +0800)  drm/radeon/hdmi: make sure we have an afmt block assigned <Alex Deucher>


Since F19 will get the 3.11 kernel anyhow and that has ~270 changes for radeon, it's probably best to simply test with that. Would you be able to test this
one and report back?
http://koji.fedoraproject.org/koji/buildinfo?buildID=462384

regards,
Michele
Comment 9 fred 2013-09-12 12:04:26 EDT
Created attachment 796923 [details]
/var/log/messages, gdm and Xorg logs witk kernel 3.11.0-300
Comment 10 fred 2013-09-12 12:13:42 EDT
Hello,

To try to restart X after I put a systemctl restart gdm in /etc/rc.local.

I didn't saw anything (i.e. black screen).

I can't use the local tty, because I have a black screen too with ctrl alt F2, ctrl alt F3 ...

I have installed kernel 3.11.0-300 of fc20 (with the skip broken option).
With this new kernel my screen tell me "No signal" and then go to sleep.

I connect with ssh from another computer and try a systemctl stop gdm and systemctl start gdm -> nothing on the screen.
I tried to run ksm instead of gdm -> nothing more.
I tried a init 3 and startx -> nothing on the screen.

I attached the log given by this kernel.

I don't know what to do now.

regards,
Fred
Comment 11 fred 2013-09-14 09:29:59 EDT
Hello,

I forgot to say that with kernel 3.11.0-300 I don't see the first services starting. There's the message "loading initramfs..." and then "no signal" on the screen.

regards,
Fred
Comment 12 fred 2013-09-15 03:29:05 EDT
Created attachment 797809 [details]
/var/log/messages, gdm and Xorg logs witk kernel 3.11.0-300 (without rhgb quiet)
Comment 13 fred 2013-09-15 03:35:42 EDT
Hello,

I forgot to erase the "rhgb quiet" parameter in grub2.cfg. I've repost the log without the "quiet mode".

There's no really differences between kernel 3.10.10 and 3.11.
After the line "fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver", 
- with kernel 3.11, there's "no signal" on the screen"
- with  kernel 3.10.10, it's a black screen.


regards,
Fred
Comment 14 Josh Boyer 2013-09-18 16:42:45 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 15 fred 2013-09-19 03:06:43 EDT
(In reply to Josh Boyer from comment #14)
> *********** MASS BUG UPDATE **************
> 
> We apologize for the inconvenience.  There is a large number of bugs to go
> through and several of them have gone stale.  Due to this, we are doing a
> mass bug update across all of the Fedora 19 kernel bugs.
> 
> Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel
> update and let us know if you issue has been resolved or if it is still
> present with the newer kernel.
> 
> If you experience different issues, please open a new bug report for those.

Hello,

I've installed the latest kernel (3.11.1-200.fc19). The problem is still present.

After the message "fb: conflicting fb hw usage radeondrmfb vs VESA VGA - removing generic driver",  there's "no signal" on the screen". 

regards,
Fred
Comment 16 fred 2013-10-06 13:51:44 EDT
Hello,

I've got some good news. The problem has disappeared with kernel 3.11.3-201.fc19.x86_64. 
It was still present with kernel-3.11.2-201.fc19.x86_64.

Do you need /var/log/messages, gdm and Xorg logs?

regards,
Fred
Comment 17 Michele Baldessari 2013-11-16 14:22:27 EST
Hi Fred,

glad to hear it works. Well there were quite a few changes with drm/radeon
between 3.11.2 and 3.11.3, so it might be that is what you were hitting:
michele@marquez:~/Devel/rh-kernel/linux-stable$ git lg v3.11.2..v3.11.3 drivers/gpu/drm/radeon/ |wc -l
21

I suggest to close this BZ if it is working now.

Thanks,
Michele
Comment 18 fred 2013-11-17 02:43:05 EST
Hello,


Yes it's working, I close this BZ.

Thanks

Fred

Note You need to log in before you can comment on or make changes to this bug.