Bug 100551 - KDE customization suggestions
Summary: KDE customization suggestions
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: beta1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-23 11:23 UTC by Peter Backlund
Modified: 2007-04-18 16:56 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-14 12:11:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
KPersonalizer patch, against kdebase-3.1.2-13 (14.88 KB, patch)
2003-07-23 11:24 UTC, Peter Backlund
no flags Details | Diff

Description Peter Backlund 2003-07-23 11:23:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
I've created a simple patch for kpersonalizer that adds Bluecurve as the default
choice for style, icons and behaviour. This would make it easy for people to
quickly move between the stock KDE (Classic/Keramik) appearance and the Red Hat
default. One thing that's missing however, is the ability to choose your default
kicker icon setup, which also would be useful (KDE setup with Konq, Kmail etc
versus BC moz/evo). I believe the ability to do that was present before? The
eyecandy selector needs some work too, I don't know exactly what the preferred
RH setup would be...maybe open for discussion?

The patch also removes the theme manager from KDE Control Center. It's going to
be removed in KDE 3.2, and it's practically useless. Adding BC to kpersonalizer
replaces the BC theme in the Theme Manager.

I've applied the patch by hand and built kpersonalizer to verify that it works,
but the src.rpm won't build due to many compile errors in other areas (vfolder
among others).

This might be a good "political" feature, for those who don't approve of RH's
KDE packaging. 


 

     

Version-Release number of selected component (if applicable):
kdebase-3.1.2-13

How reproducible:
Always

Steps to Reproduce:

    

Additional info:

Comment 1 Peter Backlund 2003-07-23 11:24:47 UTC
Created attachment 93079 [details]
KPersonalizer patch, against kdebase-3.1.2-13

Comment 5 Ngo Than 2003-08-14 12:11:16 UTC
ok, i have adjusted the patch. The next kdebase build will has this patch.
and kpersonalizer does not start at login, of course ;-)


Note You need to log in before you can comment on or make changes to this bug.