Bug 1005510 - Feature Request: rhc-fix-missing-frontend needs option to run non-interactively
Feature Request: rhc-fix-missing-frontend needs option to run non-interactively
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-07 15:28 EDT by Matt Woodson
Modified: 2015-05-14 19:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:28:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Woodson 2013-09-07 15:28:58 EDT
Description of problem:

This is a feature request.

right now rhc-fix-missing-frontend requires user interaction from the administration to run the command.  Here is the output:

========================================================
# rhc-fix-missing-frontend 521e1a525004469bc80000c9
Rebuilding the frontend for:
	521e1a525004469bc80000c9
Hit 'y' to continue, anything else to abort.
y
Fixing gear: 521e1a525004469bc80000c9 ...
Done
========================================================

It would be good to have an option, like -y, to pass the program to do this automatically.  That way we can script this to fix problems without having to be on the instance.


Version-Release number of selected component (if applicable):

rhc-node-1.13.6-1.el6oso.x86_64

How reproducible:

very, run the command


Expected results:

========================================================
# rhc-fix-missing-frontend -y 521e1a525004469bc80000c9
Rebuilding the frontend for:
	521e1a525004469bc80000c9
Fixing gear: 521e1a525004469bc80000c9 ...
Done
========================================================


Additional info:

I am proposing -y, but am not bound to it. There are other command that are rhc-* that might need this option added to them as well.
Comment 1 openshift-github-bot 2013-09-09 07:04:40 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/f89c7cc0491f3920695e5590a5569783e32944e1
Bug 1005510 - Added '-y' option to rhc-fix-missing-frontend
Comment 2 Meng Bo 2013-09-09 23:05:24 EDT
[root@ip-10-236-180-13 ~]# rhc-fix-missing-frontend -y 522e88e7a9d92ce9ba0000b9
Rebuilding the frontend for:
	-y
	522e88e7a9d92ce9ba0000b9
Fixing gear: 522e88e7a9d92ce9ba0000b9 ...
Done
[root@ip-10-236-180-13 ~]# rhc-fix-missing-frontend 522e88e7a9d92ce9ba0000b9 -y
Rebuilding the frontend for:
	522e88e7a9d92ce9ba0000b9
	-y
Fixing gear: 522e88e7a9d92ce9ba0000b9 ...
Done


The original issue is fixed, it will not need interactive action for this command.
But it will list the option -y as a gear, please refer to the result above.

And maybe -b is a better option for this, since most of the rhc tools using -b|--bypass for skip the interactive action.


And I think it also needs an usage update for this option.

[root@ip-10-236-180-13 ~]# rhc-fix-missing-frontend 
Usage: /usr/bin/rhc-fix-missing-frontend uuid uuid uuid ...
Comment 3 openshift-github-bot 2013-09-10 14:32:57 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/8d279aaedcf180449757670a8269388e15782d37
Bug 1005510 - Changed non-interactive param name for rhc-fix-missing-frontend to -b
Comment 4 Meng Bo 2013-09-17 03:37:37 EDT
# rhc-fix-missing-frontend  5238058d6cd292253f0002ad
Rebuilding the frontend for:
	5238058d6cd292253f0002ad
Fixing gear: 5238058d6cd292253f0002ad ...
Done

# rhc-fix-missing-frontend -b 5238058d6cd292253f0002ad
Rebuilding the frontend for:
	5238058d6cd292253f0002ad
Hit 'y' to continue, anything else to abort.
y
Fixing gear: 5238058d6cd292253f0002ad ...
Done



The command will be interactive only when the option -b present.
Comment 5 openshift-github-bot 2013-09-19 09:00:54 EDT
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/3baf3d7034c454a0ecb7bb103ab544b502cfba0a
Bug 1005510 - Skip interactive mode when -b option is set
Comment 6 Meng Bo 2013-09-22 04:35:30 EDT
[root@ip-10-178-10-155 ~]# rhc-fix-missing-frontend 523eab0ae6e4dc9cf40000f1
Rebuilding the frontend for:
	523eab0ae6e4dc9cf40000f1
Hit 'y' to continue, anything else to abort.
y
Fixing gear: 523eab0ae6e4dc9cf40000f1 ...
Done
[root@ip-10-178-10-155 ~]# rhc-fix-missing-frontend -b 523eab0ae6e4dc9cf40000f1
Rebuilding the frontend for:
	523eab0ae6e4dc9cf40000f1
Fixing gear: 523eab0ae6e4dc9cf40000f1 ...
Done


The issue has been fixed on devenv_3810. Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.