Bug 1005584 - Facebook authentification fails if account is created with GOA
Facebook authentification fails if account is created with GOA
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Debarshi Ray
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-08 14:38 EDT by Ghislain Vaillant
Modified: 2014-04-09 12:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-09 12:15:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 707747 None None None Never
GNOME Desktop 710363 None None None Never

  None (edit)
Description Ghislain Vaillant 2013-09-08 14:38:18 EDT
Description of problem:

A Facebook account can be successfully linked with GOA, but Empathy still fails to connect and throws a Athentification failure popup. Since the bug fix update of telepathy-gabble pushed as a result of bug #1004325, Facebook works if the account if linked from Empathy directly, instead of using GOA. 

How reproducible:

Tried on 2 computers running up-to-date Fedora 19 x86_64, 100% reproducible.

Steps to Reproduce:
1. Open GOA, Settings -> Online Accounts
2. Link your Facebook Account
3. Launch Empathy

Actual results:

A pop-up warns about the athentification failure. None of my Facebook contacts is shown in Empathy. 

Expected results:

My Facebook contacts should be shown in Empathy.

Additional info:

I have no other account sync'd besides Facebook. Again, Facebook works if GOA is bypassed and the account is sync'd directly from Empathy.
Comment 1 Martin Engbers 2013-09-15 06:02:44 EDT
I can confirm this bug on another computer running up-to-date Fedora 19 x86_64. Facebook chat works if the account is configured from within Empathy, but authorization fails for Facebook accounts configured using GOA. Google+ and Windows Live accounts are unaffected.
Comment 2 Gareth Jones 2013-09-15 16:57:08 EDT
Same issue here.
Comment 3 Debarshi Ray 2013-09-18 07:36:42 EDT
It doesn't work with Ubuntu/UOA/Empathy either. I am guessing something broke
at Facebook's end.

(In reply to Martin Engbers from comment #1)
> I can confirm this bug on another computer running up-to-date Fedora 19
> x86_64. Facebook chat works if the account is configured from within
> Empathy, but authorization fails for Facebook accounts configured using GOA.

That is because when you are using GOA it is using a different SASL mechanism -- namely X-FACEBOOK-PLATFORM [1]. Otherwise you are using DIGEST-MD5.

[1] https://developers.facebook.com/docs/chat/#platauth
Comment 4 Ghislain Vaillant 2013-09-28 06:45:52 EDT
Still happening in Gnome 3.10 (Fedora 20 alpha)
Comment 5 Viktor 2013-10-19 05:26:29 EDT
This bug is reported upstream and fixes has been pushed to master for 3.10
https://bugzilla.gnome.org/show_bug.cgi?id=710363

Note You need to log in before you can comment on or make changes to this bug.