This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1005648 - Return blank page when adding community content using admin account or visit some content page.
Return blank page when adding community content using admin account or visit ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabiano Franz
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 01:09 EDT by Yujie Zhang
Modified: 2015-05-14 21:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 12:50:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yujie Zhang 2013-09-09 01:09:09 EDT
Description of problem:

Tried to create partner and quickstart content in community, after submit, it returned blank page.

Version-Release number of selected component (if applicable):
devenv_3758

How reproducible:
always

Steps to Reproduce:
1.Login to community using admin account
2.Try to create a partner or create a quickstart content
3.

Actual results:

After submitting, it redirect to https://server/quickstarts/asgasd, but it returned the page is blank. Details see in attachment.

Expected results:

It should return correct content page after submitting.

Additional info:
Comment 1 Yujie Zhang 2013-09-09 02:06:50 EDT
It also returns blank page when visiting some content pages, like blog, forum, events, votes content page.
Comment 2 Yujie Zhang 2013-09-09 02:27:49 EDT
Found the following error in drupal log when visiting blogs page:

Type	php
Date	Monday, September 9, 2013 - 02:24
User	admin
Location	https://ec2-54-211-205-64.compute-1.amazonaws.com:8118/blogs
Referrer	https://ec2-54-211-205-64.compute-1.amazonaws.com:8118/
Message	Invalid argument supplied for foreach() in /usr/share/drupal6/includes/common.inc on line 230.
Severity	error
Hostname	203.114.244.88
Operations	

Same error for other content pages.
Comment 3 Fabiano Franz 2013-09-09 13:29:43 EDT
Pull request: https://github.com/openshift/li/pull/1884
Comment 5 Yujie Zhang 2013-09-09 23:28:08 EDT
Tested on devenv_3762, the content pages can be accessed and created successfully, so verify this bug, thanks.

Note You need to log in before you can comment on or make changes to this bug.