Bug 1005707 - Don't use default editor for displaying binary assets (images, etc)
Don't use default editor for displaying binary assets (images, etc)
Status: CLOSED CURRENTRELEASE
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
high Severity low
: ER6
: 6.0.0
Assigned To: Toni Rikkola
Tomas Livora
:
: 1008425 (view as bug list)
Depends On:
Blocks: 1009030
  Show dependency treegraph
 
Reported: 2013-09-09 04:55 EDT by Petr Široký
Modified: 2014-08-06 16:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:19:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Široký 2013-09-09 04:55:48 EDT
Description of problem:
Binary assets (e.g. images) are opened in "Default Editor" which is suited only for non-binary assets. Images should be displayed as images or not displayed at all. Similarly with other binary asset types.

Stacktrace in log:
Caused by: org.kie.commons.java.nio.IOException: java.nio.charset.MalformedInputException: Input length = 1
  at org.kie.commons.java.nio.file.Files.readAllLines(Files.java:1092)
  at org.kie.commons.io.impl.AbstractIOService.readAllString(AbstractIOService.java:371)
  at org.kie.commons.io.impl.AbstractIOService.readAllString(AbstractIOService.java:385)
  at org.uberfire.backend.server.VFSServicesServerImpl.readAllString(VFSServicesServerImpl.java:141)
  at org.uberfire.backend.server.VFSServicesServerImpl$Proxy$_$$_WeldClientProxy.readAllString(VFSServicesServerImpl$Proxy$_$$_WeldClientProxy.java)
  at sun.reflect.GeneratedMethodAccessor178.invoke(Unknown Source)
  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
  at java.lang.reflect.Method.invoke(Method.java:606)
  at org.jboss.errai.bus.server.io.ConversationalEndpointCallback.callback(ConversationalEndpointCallback.java:114)  	  ... 38 more
Caused by: java.nio.charset.MalformedInputException: Input length = 1
  at java.nio.charset.CoderResult.throwException(CoderResult.java:277)
  at sun.nio.cs.StreamDecoder.implRead(StreamDecoder.java:338)
  at sun.nio.cs.StreamDecoder.read(StreamDecoder.java:177)
  at java.io.InputStreamReader.read(InputStreamReader.java:184)
  at java.io.BufferedReader.fill(BufferedReader.java:154)
  at java.io.BufferedReader.readLine(BufferedReader.java:317)
  at java.io.BufferedReader.readLine(BufferedReader.java:382)
  at org.kie.commons.java.nio.file.Files.readAllLines(Files.java:1087)
  ... 46 more



Version-Release number of selected component (if applicable):
6.0.0-ER2
Comment 5 Edson Tirelli 2013-10-08 09:27:37 EDT
*** Bug 1008425 has been marked as a duplicate of this bug. ***
Comment 6 Toni Rikkola 2013-10-17 05:07:49 EDT
*** Bug 1019842 has been marked as a duplicate of this bug. ***
Comment 7 Lukáš Petrovický 2013-10-17 05:17:47 EDT
Raising severity as the bug now causes problems in other areas (such as bug 1019842).
Comment 8 Radovan Synek 2013-10-17 07:06:14 EDT
as this issue doesn't block bug 999885, setting severity back to low.
Comment 9 Edson Tirelli 2013-11-18 14:57:54 EST
Toni, I am raising the priority of this to match that of ticket #1009030.
Comment 10 Tomas Livora 2014-01-14 10:54:35 EST
Verified on BRMS 6.0.0-ER7

Note You need to log in before you can comment on or make changes to this bug.