Bug 1005767 - Wrong parsing of the getStorageDomainInfo output on case of ISCSI domains are used.
Wrong parsing of the getStorageDomainInfo output on case of ISCSI domains are...
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
medium Severity medium
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
Leonid Natapov
integration
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 07:25 EDT by Leonid Natapov
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.4.beta.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 05:23:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19115 None None None Never

  None (edit)
Description Leonid Natapov 2013-09-09 07:25:14 EDT
Description of problem:
when the ovirt-hosted-engine setup ask vdsm to list known domains it lists also iscsi ones. ISCSI output differes from NFS. We have a probkem to parse ISCSI output and therefore the setup fails with the following errror:
[ ERROR ] Failed to execute stage 'Environment customization': 'remotePath'
When the setup ask vdsm to list known domains it lists also iscsi ones and we fail to parse it.

That will not be an issue on fresh installations where no other domains exists

vdsm log:

getStorageDomainInfo:268 {'status': {'message': 'OK', 'code': 0}, 'info': {'uuid': '2c5db63b-64fa-4633-9e96-ad8b43368169
', 'vguuid': 'P5r0bB-n5j5-mLEx-5fGR-pqAZ-KZhA-lq84yP', 'lver': -1, 'state': 'OK', 'version': '3', 'role': 'Master', 'pool': ['c2b8fd64-0884-4140-90fc-c74a642b9840'], 'spm_id': -1, 'type': 'ISCSI', 'class': 'Data
', 'master_ver': 0, 'name': 'elad2'}}

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Try to run ovirt-hosted-engine-setup on host that was previously connected to ISCSI domain.


Actual results:
installation fails.

Expected results:
installation succeeds.

Additional info:
Comment 1 Sandro Bonazzola 2013-09-09 07:27:17 EDT
Thanks, I've all the info needed.
Comment 2 Sandro Bonazzola 2013-09-11 04:37:16 EDT
patch pushed to upstream master:

previously the getStorageDomainInfo parser assumed that
remotePath was always defined in the dictionary returned
by the call to getStorageDomainInfo.
The key is not defined for iSCSI domains so now the
parser check for remotePath availability before
trying to use its value.
Comment 3 Sandro Bonazzola 2013-09-12 05:31:42 EDT
patch merged upstream master.
Comment 6 Charlie 2013-11-27 20:19:58 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 7 Sandro Bonazzola 2013-12-05 05:48:38 EST
hosted engine is a new package, does not need errata for specific bugs during its development.

Note You need to log in before you can comment on or make changes to this bug.