Bug 1005835 - No notification appears in case not filling [GlusterFS] Option “Path” which mandatory field
No notification appears in case not filling [GlusterFS] Option “Path” which m...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity low
: ---
: 3.3.0
Assigned To: Tal Nisan
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 09:25 EDT by vvyazmin@redhat.com
Modified: 2016-02-10 12:02 EST (History)
11 users (show)

See Also:
Fixed In Version: is25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
## Screenshot (387.13 KB, image/png)
2013-09-09 09:25 EDT, vvyazmin@redhat.com
no flags Details

  None (edit)
Description vvyazmin@redhat.com 2013-09-09 09:25:03 EDT
Created attachment 795610 [details]
## Screenshot

Description of problem:
Option “Path” is mandatory field on GlusterFS Storage Domain

Version-Release number of selected component (if applicable):
RHEVM 3.3 - IS13 environment:

RHEVM:  rhevm-3.3.0-0.19.master.el6ev.noarch
PythonSDK:  rhevm-sdk-python-3.3.0.13-1.el6ev.noarch
VDSM:  vdsm-4.12.0-105.git0da1561.el6ev.x86_64
LIBVIRT:  libvirt-0.10.2-18.el6_4.9.x86_64
QEMU & KVM:  qemu-kvm-rhev-0.12.1.2-2.355.el6_4.7.x86_64
SANLOCK:  sanlock-2.8-1.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. On GlusterFS Data Center create Storage Domain (SD)

Actual results:
Option path is mandatory field

Expected results:
Option path is mandatory field, and if user decides not fill this field, user need get red frame on this field, and get note, that this field is mandatory. 

Impact on user:
none

Workaround:
none

Additional info:
Print Screen attached

/var/log/ovirt-engine/engine.log

/var/log/vdsm/vdsm.log
Comment 1 Aharon Canan 2013-09-09 09:58:39 EDT
The problem is that in case we are not filling the "Path" which is mandatory, we expect to get notification that this field is empty.
Comment 4 Aharon Canan 2013-12-29 09:47:42 EST
verified using is29

try to submit with empty path field, got an invalid color and can't continue
Comment 5 Itamar Heim 2014-01-21 17:25:06 EST
Closing - RHEV 3.3 Released
Comment 6 Itamar Heim 2014-01-21 17:25:46 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:29:18 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.