Bug 1005836 - [rhevm] Webadmin - Users - SearchBox doesnt display Templates in search for Users (Users: Templates.name =R*)
[rhevm] Webadmin - Users - SearchBox doesnt display Templates in search for U...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.4.0
Assigned To: Ravi Nori
Petr Beňas
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 09:27 EDT by David Botzer
Modified: 2016-02-10 14:38 EST (History)
10 users (show)

See Also:
Fixed In Version: ovirt-3.4.0-alpha1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-12 10:05:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
general (98.93 KB, image/png)
2013-09-09 09:27 EDT, David Botzer
no flags Details
permissions-not-found (69.80 KB, image/png)
2013-09-09 09:27 EDT, David Botzer
no flags Details
permissions (98.30 KB, image/png)
2013-09-09 09:28 EDT, David Botzer
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22373 None None None Never

  None (edit)
Description David Botzer 2013-09-09 09:27:05 EDT
Created attachment 795611 [details]
general

Description of problem:
[rhevm] Webadmin - Users - SearchBox doesnt display 
Templates in search for Users (Users: Templates.name =R*)

Version-Release number of selected component (if applicable):
3.3/is13
rhevm-3.3.0-0.19.master.el6ev.noarch

How reproducible:
always

Steps to Reproduce:
1.Select Users Tab in webadmin 
2.Verify Template name = "RHEL64-Template"
3.Type & select "Users: Templates.name =R*"
  or -- Users: Templates.name =RHEL64-Template

Actual results:
The filter/search doesnt display the requested search
- Only Users: Templates.name = * works

Expected results:
Should display all Users that have permissions in the requested Templates 

Additional info:
pic
Comment 1 David Botzer 2013-09-09 09:27:38 EDT
Created attachment 795612 [details]
permissions-not-found
Comment 2 David Botzer 2013-09-09 09:28:15 EDT
Created attachment 795613 [details]
permissions
Comment 3 Itamar Heim 2013-09-09 10:36:13 EDT
i doubt this worked since we moved to MLA in 2.2...
Comment 4 Itamar Heim 2013-09-09 10:36:41 EDT
(and if i'm correct, we should just remove the option rather than fix it)
Comment 5 Eli Mesika 2013-09-12 08:58:43 EDT
Please check with other template name that does not have the "-" chat in its name.

I suspect that "RHEL64-Template" does not work because of this sign.
Comment 6 David Botzer 2013-09-12 09:12:13 EDT
Let me try to correct this

I checked the with the default blank
Users: Templates.name =Blan* - and its ok

I also created new template from a VM called it juju, and chdecked its permissions to include admin@intrnal (Super User)

I ran filter - Users: Templates.name =j*
and its didnt display the template
Comment 8 Sandro Bonazzola 2014-01-14 03:43:45 EST
ovirt 3.4.0 alpha has been released
Comment 9 Petr Beňas 2014-02-17 08:59:33 EST
Verified in 3.4.0-0.7.beta2.
Comment 10 Itamar Heim 2014-06-12 10:05:42 EDT
Closing as part of 3.4.0

Note You need to log in before you can comment on or make changes to this bug.