Bug 1005840 - [User Portal] Clicking on 'Guide' in User Portal opens Administration Guide
[User Portal] Clicking on 'Guide' in User Portal opens Administration Guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-userportal (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Alexander Wels
movciari
ux
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 09:38 EDT by Jiri Belka
Modified: 2014-01-21 17:20 EST (History)
6 users (show)

See Also:
Fixed In Version: is18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:12:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
IE network captured data (154.63 KB, text/xml)
2013-09-09 09:38 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-09-09 09:38:01 EDT
Created attachment 795615 [details]
IE network captured data

Description of problem:
Clicking on 'Guide' in User Portal opens Administration Guide, it should open User Portal Guide.

When I click on 'Guide' in User Portal, I first get a warning about not having installed English language pack (huh, I'm using English Windows 7), then clicking the link I see Administration Guide.

Version-Release number of selected component (if applicable):
is13

How reproducible:
100%

Steps to Reproduce:
1. have clean IE
2. click 'Guide' in User Portal
3.

Actual results:
Administration guide

Expected results:
User Portal guide

Additional info:
Comment 2 Einav Cohen 2013-10-10 11:07:18 EDT
I am not sure about it, but there is a chance that all RHEV-M Guide links are currently broken (see Bug 1011430) - Alex, is that the case?
[if so - please re-open this BZ (i.e. move status to ASSIGNED)]
Comment 3 Alexander Wels 2013-10-10 11:11:10 EDT
No this was actually pointing to the wrong document, which I fixed (see gerrit). The other guide links are not working but for a different reason, and a different bz is being used to work on that.
Comment 4 Einav Cohen 2013-10-10 11:30:07 EDT
but won't the user portal guide link be broken just as the admin guide link is currently broken? 

from external_resources.properties in the rhevm branding repo:
----
obrand.webadmin.guide_url=/docs/{0}/html/Administration_Guide/index.html	obrand.userportal.guide_url=/docs/{0}/html/User_Portal_Guide/index.html
----

IIUC, the web-admin Guide link is currently broken due to the "{0}" placeholder being replaced with "en-US" instead of "en_US" (or vice versa, or a similar issue) - this is tracked via Bug 1011430, and fixed in http://gerrit.ovirt.org/#/c/19848/.

so currently - isn't the same thing happening also to the user portal guide URL (which also include the "{0}" placeholder that is being replaced with the current locale in the same manner)?
Comment 5 Alexander Wels 2013-10-10 11:38:46 EDT
There were two issues with this bug:

1. The link was actually pointing to the wrong guide.
2. The issue you describe above with the place holder being replaced, current being fixed in the other bz.

So the result of applying the patch associated with this bug is that now you still get the warning message, but once you click take me to the English version it does actually get you to the right documentation vs. it taking you to the wrong documentation.
Comment 6 Einav Cohen 2013-10-10 12:52:43 EDT
got it - thanks for the explanation.

QE: If you are verifying this bug in a RHEV-M version that doesn't contain the solution for Bug 1011430, please note that the 'Guide' link will actually direct you to a page that says:

"""
It appears that you do not have the English language pack installed. Please have your administrator install the proper language.

Please click here for the English documentation. This message will only be displayed once per session.
"""

after clicking "here", you should be directed to the user portal guide.
if you are indeed directed to the user portal guide, please move the BZ to VERIFIED.

If you are verifying this bug in a RHEV-M version that contains the solution for Bug 1011430, the 'Guide' link should behave as expected, and direct you to the user portal guide, without the intermediate page.

Thanks.
Comment 7 Itamar Heim 2014-01-21 17:12:56 EST
Closing - RHEV 3.3 Released
Comment 8 Itamar Heim 2014-01-21 17:20:59 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.