Bug 100586 - 500 error trying to delete a user
500 error trying to delete a user
Status: CLOSED DUPLICATE of bug 98929
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-23 12:05 EDT by Kambiz Aghaiepour
Modified: 2007-07-31 10:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kambiz Aghaiepour 2003-07-23 12:05:13 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
From: Robin Norwood <rnorwood@redhat.com>
Date: 23 Jul 2003 11:41:33 -0400

Kambiz Aghaiepour <kambiz@redhat.com> writes:

> Trying to delete a user, I get the following:

This looks like we're missing an on delete cascade for rhnemailaddress
when deleting a user - can you create a bug and assign it to misa or pjones?

Thanks,

-RN

>
> From: Red Hat Network <dev-null@rhn.redhat.com>
> Subject: WEB TRACEBACK from is-sat.corp.redhat.com (Wed Jul 23 11:31:45 2003)
> To: soc@redhat.com
> Date: Wed, 23 Jul 2003 11:31:45 -0400
>
>
> The following exception occured while executing this request:
>  GET
/network/users/details/delete_confirm.pxt?uid=3&brb_confirm=1&system_deletion_brb=Delete+User&pxt%3Atrap=rhn%3Adelete_user_cb
HTTP/1.1 (from browser)
>  /network/users/details/delete_confirm.pxt (from Apache)
>
> Date:
>   Wed Jul 23 11:31:45 2003
>
> Headers:
>   Accept:
text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,video/x-mng,image/png,image/jpeg,image/gif;q=0.2,*/*;q=0.1
>   Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
>   Accept-Encoding: gzip,deflate
>   Accept-Language: en-us,en;q=0.5
>   Connection: keep-alive
>   Cookie: pxt-session-cookie=133xb56c699b854c68a3182ea488eacc17bf
>   Host: is-sat.corp.redhat.com
>   Keep-Alive: 300
>   Referer:
http://is-sat.corp.redhat.com/network/users/details/delete_confirm.pxt?uid=3
>   User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
>
> Form variables:
>   brb_confirm => 1
>   pxt:trap => rhn:delete_user_cb
>   system_deletion_brb => Delete User
>   uid => 3
>
> User Information:
>   User rhsoc (id 2, org_id 1)
>
> Error notes:
>   (none)
>
> Initial Request:
>   Yes
>
> Error message:
>   RHN::Exception: DBD::Oracle::st execute failed: ORA-02292: integrity
constraint (RHSOC.RHN_EADDRESS_UID_FK) violated - child record found
> ORA-06512: at "RHSOC.RHN_ORG", line 140
> ORA-06512: at line 2 (DBD ERROR: OCIStmtExecute)
>   RHN::DB::db /usr/lib/perl5/site_perl/5.6.1/i386-linux/RHN/DB.pm 289
RHN::DB::handle_error
>   RHN::DB::User /usr/lib/perl5/site_perl/5.6.1/i386-linux/RHN/DB/User.pm 188
RHN::DB::db::call_procedure
>   Sniglets::Users /usr/lib/perl5/site_perl/5.6.1/i386-linux/Sniglets/Users.pm
173 RHN::DB::User::delete_user
>   Sniglets::Users /usr/lib/perl5/site_perl/5.6.1/i386-linux/Sniglets/Users.pm
172 (eval)
>   PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/ApacheHandler.pm 546
Sniglets::Users::delete_user_cb
>   PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/ApacheHandler.pm 82
PXT::ApacheHandler::pxt_parse_data
>   PXT::ApacheHandler
>   PXT::ApacheHandler
/usr/lib/perl5/site_perl/5.6.1/i386-linux/PXT/ApacheHandler.pm 82 (eval)
>   main /dev/null 0 PXT::ApacheHandler::handler
>   main /dev/null 0 (eval)
>
> Offending Query: BEGIN
>   rhn_org.delete_user(?);
> END;
>


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Try to delete an account on the satellite server.

Additional info:
Comment 1 Josef Komenda 2003-07-23 12:22:49 EDT
Found some time ago, aligned to rhn270.

*** This bug has been marked as a duplicate of 98929 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:42 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.