Bug 1006032 - local configuration file (.modulespath) in environment-modules package not preserved on upgrade [NEEDINFO]
local configuration file (.modulespath) in environment-modules package not pr...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
5.9
Unspecified Linux
unspecified Severity medium
: rc
: ---
Assigned To: RHEL Product and Program Management
nobody nobody
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-09 16:01 EDT by bugzilla-rh
Modified: 2014-06-02 09:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:02:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (bugzilla-rh)


Attachments (Terms of Use)

  None (edit)
Description bugzilla-rh 2013-09-09 16:01:49 EDT
Description of problem:

Updating the environment-modules package (via 'yum update') causes the locally-modified configuration file
      /usr/share/Modules/init/.modulespath
to be replaced with the generic file from the distribution package.


Version-Release number of selected component (if applicable):
    environment-modules-3.2.10-1.el5

How reproducible:

100%

Steps to Reproduce:
1. Install the environment-modules package:
      yum -y install environment-modules

2. Modify the configuration file
      echo "# This file was locally modified" >> /usr/share/Modules/init/.modulespath

3. Reinstall or update the package:
      yum -y reinstall environment-modules

Actual results:
   The file "/usr/share/Modules/init/.modulespath" is replaced with the generic file from the distribution.



Expected results:
   The locally modified configuration file "/usr/share/Modules/init/.modulespath" should be retained. The distribution version should be installed as ".modulespath.rpmnew".





Additional info:
Comment 1 Jan Synacek 2013-09-24 02:24:34 EDT
Is there any reason why this bug should be private?
Comment 2 bugzilla-rh 2013-09-24 11:01:26 EDT
(In reply to Jan Synacek from comment #1)
> Is there any reason why this bug should be private?

Nope, that wasn't my intention.
Comment 3 Jan Synacek 2013-10-01 01:59:49 EDT
Is it OK if I make the bug public then?
Comment 4 bugzilla-rh 2013-10-01 10:01:14 EDT
(In reply to Jan Synacek from comment #3)
> Is it OK if I make the bug public then?

Yes. Please. Of course. Absolutely. Don't wait. Go ahead. 

The bug report was intended to be public from the beginning.
Comment 5 RHEL Product and Program Management 2014-03-07 08:33:59 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 6 RHEL Product and Program Management 2014-06-02 09:02:30 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.