Bug 1006148 - [virtio-win][viostor][WLK]BSOD 9c happened during running WLK job "Device Path Exerciser" with virtio-win-prewhql-48 driver on winxp guest.
[virtio-win][viostor][WLK]BSOD 9c happened during running WLK job "Device Pat...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virtio-win (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 02:35 EDT by guo jiang
Modified: 2014-09-16 08:43 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-16 08:43:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
winxp-blk48-DEP-BSOD9c (18.85 MB, application/zip)
2013-09-10 02:49 EDT, guo jiang
no flags Details
winxp-blk-48-cpk (1.56 MB, application/octet-stream)
2013-09-10 02:51 EDT, guo jiang
no flags Details
winxp-blk-48-cpk-new (1.24 MB, application/octet-stream)
2013-09-10 03:11 EDT, guo jiang
no flags Details

  None (edit)
Description guo jiang 2013-09-10 02:35:18 EDT
Description of problem:
BSOD 9c happened during running WLK job "Device Path Exerciser" with virtio-win-prewhql-48 driver on winxp guest.

Version-Release number of selected component (if applicable):
  Red Hat Enterprise Linux Server release 6.4 (Santiago)
  kernel-2.6.32-414.el6.x86_64    
  qemu-kvm-rhev-0.12.1.2-2.397.el6.x86_64
  virtio-win-prewhql-0.1-48
  spice-server-0.12.4-2.el6.x86_64
  seabios-0.6.1.2-28.el6.x86_64
  vgabios-0.6b-3.7.el6.noarch

How reproducible:
100%

Steps to Reproduce:
1.Boot guest with CLI:
 /usr/libexec/qemu-kvm -M rhel6.5.0 -m 2G -smp 2,cores=2 -cpu cpu64-rhel6 -usb -device usb-tablet -drive file=winxp-32.raw,format=raw,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0,bootindex=1 -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device rtl8139,netdev=hostnet0,mac=00:53:55:51:3c:a0,bus=pci.0,addr=0x6 -netdev tap,sndbuf=0,id=hostnet1,script=/etc/qemu-ifup0,downscript=no -device rtl8139,netdev=hostnet1,mac=00:53:45:51:3c:10,bus=pci.0,addr=0x7 -uuid 179270aa-45bb-4394-a9cf-3e8114d8556e -no-kvm-pit-reinjection -drive file=disk1.raw,if=none,id=drive-virtio1,cache=none,werror=stop,rerror=stop,format=raw -device virtio-blk-pci,drive=drive-virtio1,id=virtio-blk-pci1 -drive file=disk2.raw,if=none,id=drive-virtio2,cache=none,werror=stop,rerror=stop,format=raw -device virtio-blk-pci,drive=drive-virtio2,id=virtio-blk-pci2 -drive file=disk3.raw,if=none,id=drive-virtio3,cache=none,werror=stop,rerror=stop,format=raw -device virtio-blk-pci,drive=drive-virtio3,id=virtio-blk-pci3 -drive file=disk4.raw,if=none,id=drive-virtio4,cache=none,werror=stop,rerror=stop,format=raw -device virtio-blk-pci,drive=drive-virtio4,id=virtio-blk-pci4 -chardev socket,id=111a,path=/tmp/monitor-winxp-32-block,server,nowait -mon chardev=111a,mode=readline -name winxp32-block-48 -vnc :1 -vga cirrus -rtc base=localtime,clock=host,driftfix=slew -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0 -monitor stdio

2.running WLK job "Device Path Exerciser"

3.

Actual results:
BSOD 9C happened when running task "RunJob - Device Path Exerciser - Library Job"

Expected results:
"Device Path Exerciser" job could pass without any error.

Windbg info:
Use !analyze -v to get detailed debugging information.

BugCheck C9, {c, b791daec, 0, 0}

*** ERROR: Module load completed but symbols could not be loaded for viostor.sys
Probably caused by : viostor.sys

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

DRIVER_VERIFIER_IOMANAGER_VIOLATION (c9)
The IO manager has caught a misbehaving driver.
Arguments:
Arg1: 0000000c, Invalid IOSB in IRP at APC IopCompleteRequest (appears to be on
	stack that was unwound)
Arg2: b791daec, IOSB address
Arg3: 00000000, IRP address
Arg4: 00000000

Debugging Details:
------------------


BUGCHECK_STR:  0xc9_c

DRIVER_VERIFIER_IO_VIOLATION_TYPE:  c

IOSB_ADDRESS: ffffffffb791daec

IRP_ADDRESS:  8a6c4f00

DEFAULT_BUCKET_ID:  DRIVER_FAULT

PROCESS_NAME:  devpathexer.exe

DEVICE_OBJECT: 89af8a30

DRIVER_OBJECT: 89b8ea08

IMAGE_NAME:  viostor.sys

DEBUG_FLR_IMAGE_TIMESTAMP:  50b4b225

MODULE_NAME: viostor

FAULTING_MODULE: bacbc000 viostor

LAST_CONTROL_TRANSFER:  from 80658714 to 804f9f33

STACK_TEXT:  
b791dc84 80658714 000000c9 0000000c b791daec nt!KeBugCheckEx+0x1b
b791dca0 804f4b55 8a6c4f40 b791dd40 b791dd44 nt!IovpCompleteRequest+0x4c
b791dcfc 804ff843 8a6c4f40 b791dd48 b791dd3c nt!IopCompleteRequest+0x39
b791dd4c 806e6ef2 00000001 00000000 b791dd64 nt!KiDeliverApc+0xb3
b791dd4c 77c43ab1 00000001 00000000 b791dd64 hal!HalpApcInterrupt+0xc6
WARNING: Frame IP not in any known module. Following frames may be wrong.
00c1feec 00000000 00000000 00000000 00000000 0x77c43ab1


STACK_COMMAND:  kb

FOLLOWUP_NAME:  MachineOwner

FAILURE_BUCKET_ID:  0xc9_c_VRF_IMAGE_viostor.sys_DATE_2012_11_27

BUCKET_ID:  0xc9_c_VRF_IMAGE_viostor.sys_DATE_2012_11_27

Followup: MachineOwner
---------
Comment 1 guo jiang 2013-09-10 02:49:44 EDT
Created attachment 795860 [details]
winxp-blk48-DEP-BSOD9c
Comment 2 guo jiang 2013-09-10 02:51:22 EDT
Created attachment 795861 [details]
winxp-blk-48-cpk
Comment 5 guo jiang 2013-09-10 03:11:00 EDT
Created attachment 795865 [details]
winxp-blk-48-cpk-new
Comment 6 Vadim Rozenfeld 2013-09-10 05:16:16 EDT
Why virtio-win-prewhql-0.1-48? 
The most recent build was 69.

Cheers,
Vadim.
Comment 8 Ronen Hod 2013-09-18 03:37:42 EDT
Mike,

Can you please try if latest drivers solve the problem. If it is solved then we will have to use them for WLK.
Vadim says that it resembles , so can you try to turn on the flexpriority.
Comment 11 RHEL Product and Program Management 2013-10-16 21:15:08 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 12 Vadim Rozenfeld 2013-11-30 04:21:27 EST
Any update on this issue?

Thanks,
Vadim.

Note You need to log in before you can comment on or make changes to this bug.