Bug 1006279 - Native ping pong IO coherence is failing on smb mount
Native ping pong IO coherence is failing on smb mount
Status: CLOSED DUPLICATE of bug 1002701
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Christopher R. Hertel
surabhi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 07:22 EDT by surabhi
Modified: 2014-09-28 20:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 08:19:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached is the smb.conf and vol file for reference (316 bytes, text/plain)
2013-09-10 13:52 EDT, surabhi
no flags Details

  None (edit)
Description surabhi 2013-09-10 07:22:18 EDT
Description of problem:
When I run native ping pong from cifs mount , the data increment value remains 
same and it doesn't increases with the number of instances.

Also the lock values are too low.

For smbtorture, the data increment is happening but after I start the third instance the lock values are going to 3 and remains at the same value.the locks are no more changing with the number of instances.

Version-Release number of selected component (if applicable):
glusterfs-geo-replication-3.4.0.33rhs-1.el6rhs.x86_64
glusterfs-api-3.4.0.33rhs-1.el6rhs.x86_64
samba-glusterfs-3.6.9-160.3.el6rhs.x86_64
glusterfs-3.4.0.33rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4.0.33rhs-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.33rhs-1.el6rhs.x86_64
glusterfs-debuginfo-3.4.0.33rhs-1.el6rhs.x86_64
glusterfs-libs-3.4.0.33rhs-1.el6rhs.x86_64
glusterfs-server-3.4.0.33rhs-1.el6rhs.x86_64


How reproducible:
Always

Steps to Reproduce:
1.Create a dis-rep volume
2.Mount it via cifs on linux client
3.Run ping pong from different mount points on the same file.

[Sep-10-2013- 6:55:49] >./ping_pong -rw  newfile1 5
data increment = 1
      37 locks/sec

[Sep-10-2013- 6:55:46] >./ping_pong -rw newfile1 5
data increment = 1
      40 locks/sec

4.Run smbtorture : 
smbtorture //10.16.159.237/gluster-new-vol raw.ping-pong -U root%redhat --option=torture:filename=john --option=torture:num_locks=10 --option=torture:read=true --option=torture:write=true


Actual results:

root@RHEL6 [Sep-10-2013- 6:55:49] >./ping_pong -rw  newfile1 5
data increment = 1
      37 locks/sec
root@RHEL6 [Sep-10-2013- 6:55:46] >./ping_pong -rw newfile1 5
data increment = 1
      40 locks/sec

root@RHEL6 [Sep-10-2013- 6:53:40] >smbtorture //10.16.159.237/gluster-new-vol raw.ping-pong -U root%redhat --option=torture:filename=john --option=torture:num_locks=10 --option=torture:read=true --option=torture:write=true
Using seed 1378810472
time: 2013-09-10 06:54:32.854636
test: ping-pong
time: 2013-09-10 06:54:32.855763
data increment = 1
data increment = 2
       3 locks/sec

root@RHEL6 [Sep-10-2013- 6:53:45] >smbtorture //10.16.159.76/gluster-new-vol raw.ping-pong -U root%redhat --option=torture:filename=john --option=torture:num_locks=10 --option=torture:read=true --option=torture:write=true
Using seed 1378810484
time: 2013-09-10 06:54:44.773363
test: ping-pong
time: 2013-09-10 06:54:44.774799
data increment = 2
       3 locks/sec


Expected results:
Data increment should happen with each instance.
Lock values should keep printing and it should not be very low.


Additional info:
Posted the issue which I observed till now.Will debug more of it and will update the bz with more logs.
Comment 1 surabhi 2013-09-10 07:28:10 EDT
The same behaviour was not observed in previous builds.

Ping pong test details :
Testinbg IO Coherence

 ping_pong -rw test.dat N

You'll probably see a much lower locking rate. This is because ping_pong is now doing a one byte read and a one byte write after each lock. It also prints a "data increment" value, which should be equal to the number of nodes that is running the ping_pong test (I'm afraid it only supports up to 256 nodes with this test).

If the "data increment" value doesn't equal the number of nodes currently running the ping_pong test, or if it doesn't print a lock rate once per second, or if the lock rate starts to approach zero, then you have a bug. Talk to your vendor.

The locking rate this prints is a simple measure of your IO contention rate. Bigger numbers are better. 

For further details:
https://wiki.samba.org/index.php/Ping_pong
Comment 3 surabhi 2013-09-10 13:52:10 EDT
Created attachment 796085 [details]
Attached is the smb.conf and vol file for reference

Attached vol file and smb.conf for reference.
Comment 4 Sudhir D 2013-09-11 08:19:55 EDT
The issue seem to be same as that found in FUSE. Closing this bug as duplicate of bz# 1002701

*** This bug has been marked as a duplicate of bug 1002701 ***

Note You need to log in before you can comment on or make changes to this bug.