Bug 100629 - klaptopdaemon: does not notice if ACPI modules are loaded afterwards
Summary: klaptopdaemon: does not notice if ACPI modules are loaded afterwards
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: kdeutils   
(Show other bugs)
Version: beta1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-23 19:21 UTC by Aleksey Nogin
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-03 08:25:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2003-07-23 19:21:55 UTC
When ACPI is used, kdelaptopdeamon does not work. It needs to know how to parse
ACPI data.

Comment 1 Aleksey Nogin 2003-07-24 22:57:57 UTC
Hm, according to some upstream bugs, klaptomdaemon does support ACPI (see, for
example, http://bugs.kde.org/show_bug.cgi?id=48983; and
http://bugs.kde.org/show_bug.cgi?id=37905 explicitly says "2002-08-31 10:58 ...
current klaptopdaemon HEAD code already has this feature" and "2002-10-03 20:00
... This was fixed a while back in CVS it will be included in 3.1.")

So, why isn't it working in beta1 (klaptopdaemon simply draws an X'ed battery
icon and claims the machine does not have APM)?

Comment 2 Gerald Teschl 2003-07-26 13:28:59 UTC
It works for me (ever since 9). Did you load the ac/battery modules?
What does /proc/acpi/battery say?



Comment 3 Ngo Than 2003-07-28 20:08:00 UTC
yes, for working the ac/battery modules should be loaded before. Does it work
for you?

Comment 4 Aleksey Nogin 2003-07-29 07:09:47 UTC
Ah, yes - I believe I loaded the modules _after_ I started the KDE session. So,
I guess, the only bug here is that it only checks at startup and does not notice
if modules are loaded afterwards. 

Except that now it says that my battery is 152% charged...

Comment 5 Ngo Than 2003-07-29 09:35:58 UTC
strange, the percentage is correctly showed for me. What for battery time do you
have by 152% charged?

Comment 6 Gerald Teschl 2003-07-29 10:08:06 UTC
Please check the content of /proc/acpi/battery to see if this is a kde
parsing bug or an acpi bug.

It works fine here, even with two batteries in the laptop.

Comment 7 Gerald Teschl 2003-07-31 10:34:13 UTC
Sorry, it does not work with two batteries (it did with shrike). I get 163%
as well.

Comment 8 Aleksey Nogin 2003-07-31 10:38:44 UTC
I did not have a chance to do much tesing yet, but I get 152% (and no time
reported) with just one battery. But that is only on AC - when running on
battery power, the percentages and the time appear correct.

Comment 9 Gerald Teschl 2003-07-31 10:55:09 UTC
With one battery everything is fine for me. With two batteries it seems
to forget to divide by two (it displays 170% when BAT1 is 70% and BAT2 100%
charged). AC or not makes no difference. 

If you compare "remaining capacity" from /proc/acpi/battery/Bat1/state
with "design capacity" from /proc/acpi/battery/Bat1/info, does acpi
give correct values?



Comment 10 Aleksey Nogin 2003-08-01 05:52:54 UTC
Interesting, for some reason when AC is plugged in, the design capasity is
reported instead of the actual one:

On AC:

% cat /proc/acpi/battery/BAT0/state
present:                 yes
capacity state:          ok
charging state:          unknown
present rate:            unknown
remaining capacity:      66000 mWh
present voltage:         16519 mV

% cat /proc/acpi/battery/BAT0/info
present:                 yes
design capacity:         66000 mWh
last full capacity:      43580 mWh
battery technology:      rechargeable
design voltage:          14800 mV
design capacity warning: 3000 mWh
design capacity low:     1000 mWh
capacity granularity 1:  200 mWh
capacity granularity 2:  200 mWh
model number:            0004M778
serial number:           1403
battery type:            LION
OEM info:                SANYO

Right after AC is unplugged:

% cat /proc/acpi/battery/BAT0/state
present:                 yes
capacity state:          ok
charging state:          discharging
present rate:            24629 mW
remaining capacity:      41620 mWh
present voltage:         16519 mV

% cat /proc/acpi/battery/BAT0/info
present:                 yes
design capacity:         66000 mWh
last full capacity:      43580 mWh
battery technology:      rechargeable
design voltage:          14800 mV
design capacity warning: 3000 mWh
design capacity low:     1000 mWh
capacity granularity 1:  200 mWh
capacity granularity 2:  200 mWh
model number:            0004M778
serial number:           1403
battery type:            LION
OEM info:                SANYO


Comment 11 Ngo Than 2003-08-01 08:39:13 UTC
Aleksey Nogin: it seems that it's not a bug in KDE, but more in bios or kernel!
Gerald Teschl: i will try to reproduce it on my laptop, but it looks like a bug
in KDE!

Comment 12 Gerald Teschl 2003-08-01 18:45:38 UTC
It looks like after a reboot it will handle the two batteries case fine
here. (/proc/acpi list correct values for me)

Comment 13 Ngo Than 2003-08-03 08:25:17 UTC
Gerald Teschl: it handles 2 batteries fine on my laptop.
I think i can close this bug as NOTABUG, because it's really not a bug here.


Note You need to log in before you can comment on or make changes to this bug.