Bug 1006300 - rdesktop-1.8.0-1.fc19.x86_64 breaks connection to Windows Server 2008 R2
rdesktop-1.8.0-1.fc19.x86_64 breaks connection to Windows Server 2008 R2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rdesktop (Show other bugs)
19
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 08:07 EDT by Harald Reindl
Modified: 2014-06-18 05:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-25 13:58:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-09-10 08:07:47 EDT
rdesktop-1.8.0-1.fc19.x86_64 fails to connect to a Windows Server 2008 R2 with the following errors as well as a segfault, downgrade to 1.7.1-2.fc19 and all works fine again

Autoselected keyboard map de
ERROR: CredSSP: Initialize failed, do you have correct kerberos tgt initialized ?
Connection established using SSL.
Comment 1 Harald Reindl 2013-09-10 17:45:12 EDT
never seen such a bullshit
palying around with all sorts of params and permanently segfaults
the best result is a shortly open black window
how can someone push such a bad broken update and not test standard windows connections with is the only usecase for rdesktop at all?

Autoselected keyboard map de
NOT IMPLEMENTED: PDU 3
NOT IMPLEMENTED: PDU 5
NOT IMPLEMENTED: PDU 8
NOT IMPLEMENTED: PDU 15
NOT IMPLEMENTED: PDU 9
NOT IMPLEMENTED: PDU 5
NOT IMPLEMENTED: PDU 3
NOT IMPLEMENTED: PDU 15
NOT IMPLEMENTED: PDU 15
WARNING: Unexpectedly large redirection cookie
Comment 2 Harald Reindl 2013-10-30 17:42:17 EDT
nobody cares?

damned do *not* update packages if you do not care about regressions
period
Comment 3 Dominik 'Rathann' Mierzejewski 2013-12-22 19:42:21 EST
Sorry, I didn't have a W2k8 server to test it. It worked just fine with an old WinXP box I had. I do care, I just didn't have time to work on this yet. Why don't you apply for co-maintainer status since you both care and have a test environment? I'll be building 1.8.1 shortly.
Comment 4 Harald Reindl 2013-12-22 19:45:07 EST
thanks for feedback, i have not enough knowledge about this apckage at all except how to exlude it to be upgraded - the "test environment" is the VMware vCenter Server crontrolling the complete company infrastructure....
Comment 5 Dominik 'Rathann' Mierzejewski 2013-12-22 20:17:03 EST
Please check if this one works for you:
https://admin.fedoraproject.org/updates/rdesktop-1.8.1-1.fc19
Comment 6 Harald Reindl 2013-12-22 20:23:47 EST
yep - see my karma at bodhi
thank you!

Note You need to log in before you can comment on or make changes to this bug.