Bug 1006339 - [RFE] Account provider: method for delete user and group should/have to be with the same name
[RFE] Account provider: method for delete user and group should/have to be wi...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: openlmi-providers (Show other bugs)
7.0
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Tomáš Bžatek
Petr Sklenar
: FutureFeature
Depends On:
Blocks: 922084
  Show dependency treegraph
 
Reported: 2013-09-10 09:07 EDT by Petr Sklenar
Modified: 2015-03-03 18:06 EST (History)
3 users (show)

See Also:
Fixed In Version: openlmi-providers-0.3.0-1.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:25:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Sklenar 2013-09-10 09:07:42 EDT
Description of problem:
see
http://rrakus.fedorapeople.org/openlmi-account/doc/usage.html#delete-user
Why do you have two names for deletion? Its not user friendly. User uses .DeleteUser() and group uses .delete()

user acci.DeleteUser()
group grp.delete()

Version-Release number of selected component (if applicable):
openlmi-account-0.1.1-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. acci.DeleteUser() vs grp.delete()
2. what about to have some option for user.delete() like delete home? 

Actual results:
two names of the methods
user is messed

Expected results:
one name; .delete() seems to be OK for the both
user is not messed

Additional info:
Comment 2 Roman Rakus 2013-10-01 07:55:09 EDT
Fixed upstream.
Comment 5 Ludek Smid 2014-06-13 09:25:37 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.