Bug 1006371 - horizon [Havana]: unclear error message when trying to run too many instances (possibly wrong error from log)
horizon [Havana]: unclear error message when trying to run too many instances...
Status: CLOSED UPSTREAM
Product: RDO
Classification: Community
Component: python-django-horizon (Show other bugs)
unspecified
x86_64 All
unspecified Severity medium
: ---
: ---
Assigned To: Matthias Runge
Ami Jeain
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 10:04 EDT by Dafna Ron
Modified: 2015-06-04 17:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-05-26 07:37:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log (2.95 KB, application/x-xz)
2013-09-10 10:04 EDT, Dafna Ron
no flags Details
horizon log (228 bytes, application/x-xz)
2013-09-10 10:12 EDT, Dafna Ron
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1223361 None None None Never

  None (edit)
Description Dafna Ron 2013-09-10 10:04:17 EDT
Created attachment 796019 [details]
log

Description of problem:

I tried running 100 very large flavoured instances which will of course could not be run. 
the error we see in the UI is 

Error: Quota exceeded for cores,instances,ram: Requested 800, but already used 0 of 20 cores (HTTP 413) (Request-ID: req-0c854c89-89d9-48ce-96e2-eca07bbbc8f5)

This message is unclear since I was trying to run 100 instances (not 800) so it's probably the ram and also, if 0 out of 20 are used, I should be able to run instances. 

looking at the log I can see that there is another error which makes a lot more scene: 

tried to run 100 instances. Can only run 2 more instances of this type.

Version-Release number of selected component (if applicable):

havana python-django-horizon-2013.1.3-2.el6ost.noarch
installed on rhel6

How reproducible:

100%

Steps to Reproduce:
1. install AIO and try to run a large number of instances with the largest flavor
2.
3.

Actual results:

we get the following unclear error: 

Error: Quota exceeded for cores,instances,ram: Requested 800, but already used 0 of 20 cores (HTTP 413) (Request-ID: req-0c854c89-89d9-48ce-96e2-eca07bbbc8f5)


Expected results:

I think the second message from the logs will be clearer: 

HTTP exception thrown: Quota exceeded for cores,instances,ram: Requested 800, but already used 0 of 20 cores


Additional info: full api log
Comment 2 Dafna Ron 2013-09-10 10:12:29 EDT
Created attachment 796023 [details]
horizon log
Comment 3 Matthias Runge 2013-09-23 07:54:05 EDT
happens on all other releases as well.

Note You need to log in before you can comment on or make changes to this bug.