Bug 1006591 - [abrt] gparted-0.16.1-2.fc19: g_logv: Process /usr/sbin/gpartedbin was killed by signal 5 (SIGTRAP)
[abrt] gparted-0.16.1-2.fc19: g_logv: Process /usr/sbin/gpartedbin was killed...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gparted (Show other bugs)
19
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Deji Akingunola
Fedora Extras Quality Assurance
abrt_hash:109950f676ebf308a8b80ef363c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-10 17:16 EDT by Jared
Modified: 2014-03-07 01:30 EST (History)
1 user (show)

See Also:
Fixed In Version: gparted-0.18.0-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-07 01:30:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (162.42 KB, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details
File: cgroup (140 bytes, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details
File: core_backtrace (27.69 KB, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details
File: dso_list (7.26 KB, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details
File: environ (233 bytes, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details
File: maps (26.11 KB, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details
File: open_fds (327 bytes, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details
File: proc_pid_status (762 bytes, text/plain)
2013-09-10 17:17 EDT, Jared
no flags Details

  None (edit)
Description Jared 2013-09-10 17:16:58 EDT
Description of problem:
I plugged in the USB thumbdrive, then tried to repartition and reformat it.

This error most likely was caused because the drive was currently mounted when I tried to repartition and format it.

After unmounting the drive the partition and format completed successfully.

Version-Release number of selected component:
gparted-0.16.1-2.fc19

Additional info:
reporter:       libreport-2.1.6
backtrace_rating: 4
cmdline:        /usr/sbin/gpartedbin
crash_function: g_logv
executable:     /usr/sbin/gpartedbin
kernel:         3.10.10-200.fc19.i686
runlevel:       N 5
uid:            0
var_log_messages: Sep 10 16:51:32 localhost abrt[5381]: Saved core dump of pid 5153 (/usr/sbin/gpartedbin) to /var/tmp/abrt/ccpp-2013-09-10-16:51:30-5153 (86462464 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #0 g_logv at /lib/libglib-2.0.so.0
 #1 g_log at /lib/libglib-2.0.so.0
 #2 glibmm_unexpected_exception at exceptionhandler.cc:71
 #3 Glib::exception_handlers_invoke at exceptionhandler.cc:150
 #4 Glib::SignalProxyNormal::slot0_void_callback at signalproxy.cc:99
 #5 g_cclosure_marshal_VOID__VOID at /lib/libgobject-2.0.so.0
 #6 g_closure_invoke at /lib/libgobject-2.0.so.0
 #7 signal_emit_unlocked_R at /lib/libgobject-2.0.so.0
 #8 g_signal_emit_valist at /lib/libgobject-2.0.so.0
 #9 g_signal_emit at /lib/libgobject-2.0.so.0
Comment 1 Jared 2013-09-10 17:17:01 EDT
Created attachment 796162 [details]
File: backtrace
Comment 2 Jared 2013-09-10 17:17:04 EDT
Created attachment 796163 [details]
File: cgroup
Comment 3 Jared 2013-09-10 17:17:07 EDT
Created attachment 796164 [details]
File: core_backtrace
Comment 4 Jared 2013-09-10 17:17:10 EDT
Created attachment 796165 [details]
File: dso_list
Comment 5 Jared 2013-09-10 17:17:12 EDT
Created attachment 796166 [details]
File: environ
Comment 6 Jared 2013-09-10 17:17:15 EDT
Created attachment 796167 [details]
File: limits
Comment 7 Jared 2013-09-10 17:17:17 EDT
Created attachment 796168 [details]
File: maps
Comment 8 Jared 2013-09-10 17:17:20 EDT
Created attachment 796169 [details]
File: open_fds
Comment 9 Jared 2013-09-10 17:17:22 EDT
Created attachment 796170 [details]
File: proc_pid_status
Comment 10 Fedora Update System 2014-02-21 01:26:22 EST
gparted-0.18.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gparted-0.18.0-1.fc19
Comment 11 Fedora Update System 2014-02-22 13:14:35 EST
Package gparted-0.18.0-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gparted-0.18.0-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2930/gparted-0.18.0-1.fc19
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2014-03-07 01:30:13 EST
gparted-0.18.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.