Bug 1006647 - Warning message in Italian needs to be fixed
Warning message in Italian needs to be fixed
Status: CLOSED WONTFIX
Product: Red Hat Satellite 5
Classification: Red Hat
Component: i18n (Show other bugs)
560
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Grant Gainey
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2013-09-10 22:50 EDT by Francesco Valente
Modified: 2017-06-20 06:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-20 06:56:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Wrong translation (193.04 KB, image/png)
2013-09-10 22:50 EDT, Francesco Valente
no flags Details

  None (edit)
Description Francesco Valente 2013-09-10 22:50:02 EDT
Created attachment 796222 [details]
Wrong translation

Description of problem:

Under Configuration -> Configuration Channels -> Create new config channel (if left empty) the warning message in Italian:

Configuration channel label is required.
Configuration channel name is required.
Configuration channel description is required.

needs a fix.

Version-Release number of selected component (if applicable):


How reproducible:

Configuration -> Configuration Channels -> Create ne config channel (leaving all fields empty) select the Create Config channel button

Steps to Reproduce:
1.
2.
3.

Actual results:

The translation of the warning message is wrong: È necessaria una Nome del canale di configurazione.

Expected results:

È necessario un Nome del canale di configurazione.

Additional info:
Comment 1 Stephen Herr 2013-10-09 11:24:45 EDT
This is a valid problem, but is difficult to fix. Currently the way this works is that those error messages are constructed strings. So, there is a string somewhere that is:
"{0} is required."
(and others, like "{0} contains invalid characters. In addition to alphanumeric characters, '-', '_', and '.' are allowed.")
And other strings that are:
"Configuration channel label"
"Configuration channel name"
"Configuration channel description"

Then when we are validating the config channel input we pair the appropriate strings together to form the error message displayed. Translations into different languages can move around the location of the key by moving "{0}", but there is no way for us to know to change the gender based on the key.

The way to fix this is to forget completely about parametrizing the error messages in this way and just have a separate string for every single possible error message. That would required changing a lot of error messages and getting the new strings translated properly. Doable, but a lot more work than updating a bad translation.
Comment 2 Tomas Lestach 2015-11-16 11:07:54 EST
Resetting to default owner.
Comment 3 Grant Gainey 2017-06-20 06:56:06 EDT
Given where Sat5 is in its lifecycle, and given that addressing this would require rethinking pretty much all of our localization (since it is unlikely to be just these strings, or just Italian, that is affected), I am closing this as WONTFIX

Note You need to log in before you can comment on or make changes to this bug.