Bug 1006691 - Duplicate Pressgang Header When Using PressGang Next
Duplicate Pressgang Header When Using PressGang Next
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Lee Newson
Vikram Goyal
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 02:21 EDT by Vikram Goyal
Modified: 2013-11-07 21:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-07 21:11:04 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
PressGang Duplicate Header (244.94 KB, image/png)
2013-09-11 02:21 EDT, Vikram Goyal
no flags Details

  None (edit)
Description Vikram Goyal 2013-09-11 02:21:18 EDT
Created attachment 796264 [details]
PressGang Duplicate Header

Steps to reproduce:

Open a book via Docbuilder.
Browse to a topic.
Click on "Edit this topic with PressGang CCMS Next"
You will see two Pressgang headers.

See attached screenshot.
Comment 1 Lee Newson 2013-09-11 02:53:29 EDT
Just want to add this disclaimer:

The User Script that adds this link isn't something that is actually part of PressGang and is just something I personally wrote when someone asked for it (remember the next UI is basically just a test version that is running on the production server, so we won't actually create something supported that links to it, like the normal editor links).

Anyways I'll take a look when I get a chance, for now you'll just have to open it in a new tab, or install the additional New Tabs User Script.
Comment 2 Matthew Casperson 2013-09-11 15:58:03 EDT
At this point PG next is not going anywhere, so I think we should look at making the editor links include next as a standard, so something like:

Edit this topic in <link>PressGang</link> or <link>PressGang Next</link>
Comment 3 Lee Newson 2013-09-11 23:14:42 EDT
I've fixed the root cause of this, which is that the publican settings on the docbuilder weren't reconfigured when it was updated.

The bit that was missing was to change "<xslparam name="ulink.target"/>" to "<xslparam name="ulink.target" select="_top" />" in /usr/share/publican/xsl/xhtml-common.xsl

Anyways we'll have to rebuild all the books for this fix to go live. As for Matt's comment, a separate RFE should be created for that.
Comment 4 Lee Newson 2013-09-11 23:38:24 EDT
Changing this bug back to ASSIGNED, as that parameter should have worked however upon testing, it isn't getting inserted anymore. I'll have to have a look at why the xsl transform is ignoring that parameter (this used to work with publican 3.1.5).
Comment 5 Lee Newson 2013-09-16 00:33:05 EDT
Found the problem and it was a config error on my part. This should now be fixed, however we'll have to rebuild all the books before it will be effective.

Note You need to log in before you can comment on or make changes to this bug.