Bug 1006727 - vdsmd fails to start after (after boot and) registration on oVirt Node (Fedora 19)
vdsmd fails to start after (after boot and) registration on oVirt Node (Fedor...
Status: CLOSED NOTABUG
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.3
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Kenigsberg
Haim
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-11 03:56 EDT by Fabian Deutsch
Modified: 2013-09-11 04:31 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-11 04:31:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-09-11 03:56:06 EDT
Description of problem:
vdsmd doesn't come up after registering Node with Engine and rebooting the Node.

Version-Release number of selected component (if applicable):
vdsm-4.12.1-2

How reproducible:
Always

Steps to Reproduce:
1. Install Node with vdsm: http://fedorapeople.org/~fabiand/node/ovirt-node-iso-3.0.1-1.0.2.vdsm.fc19.iso
2. Configure network and register with Engine
3. Set host into maintenance mode 
4. Reboot the Node

Actual results:
vdsmd service is in a failed state

Expected results:
vdsmd service is running

Additional info:
This doesn'ts eem to be bug #999664
Comment 1 Fabian Deutsch 2013-09-11 04:01:42 EDT
The snippet from journal:
[root@foolocalhost admin]# journalctl -u vdsmd
-- Logs begin at Wed 2013-09-11 06:49:43 UTC, end at Wed 2013-09-11 07:42:02 UTC. --
Sep 11 06:50:04 localhost systemd[1]: Starting Virtual Desktop Server Manager...
Sep 11 06:50:05 localhost systemd-vdsmd[1697]: Configuring a self-signed VDSM host certificate: [  OK  ]
Sep 11 06:50:09 localhost systemd-vdsmd[1697]: Traceback (most recent call last):
Sep 11 06:50:09 localhost systemd-vdsmd[1697]: File "/usr/bin/vdsm-tool", line 143, in <module>
Sep 11 06:50:09 localhost systemd-vdsmd[1697]: sys.exit(main())
Sep 11 06:50:09 localhost systemd-vdsmd[1697]: File "/usr/bin/vdsm-tool", line 140, in main
Sep 11 06:50:09 localhost systemd-vdsmd[1697]: return tool_command[cmd]["command"](*args[1:])
Sep 11 06:50:09 localhost systemd-vdsmd[1697]: File "/usr/lib64/python2.7/site-packages/vdsm/tool/sanlock.py", line 41, in sanlock_check_service
Sep 11 06:50:09 localhost systemd-vdsmd[1697]: sanlock_pid = open(SANLOCK_PID, "r").readline().strip()
Sep 11 06:50:09 localhost systemd-vdsmd[1697]: IOError: [Errno 2] No such file or directory: '/var/run/sanlock/sanlock.pid'
Sep 11 06:50:13 localhost systemd-vdsmd[1697]: Attempting to restart sanlock service:[  OK  ]
Sep 11 06:50:21 localhost systemd-vdsmd[1697]: Starting configure libvirt to VDSM ...
Sep 11 06:50:21 localhost systemd-vdsmd[1697]: checking certs..
Sep 11 06:50:21 localhost systemd-vdsmd[1697]: WARNING: persistent config storage not available
Sep 11 06:50:21 localhost systemd-vdsmd[1697]: =Done configuring libvirt=
Sep 11 06:50:43 localhost systemd-vdsmd[1697]: Starting network...
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: Traceback (most recent call last):
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: File "/usr/bin/vdsm-tool", line 143, in <module>
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: sys.exit(main())
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: File "/usr/bin/vdsm-tool", line 140, in main
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: return tool_command[cmd]["command"](*args[1:])
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: File "/usr/lib64/python2.7/site-packages/vdsm/tool/service.py", line 361, in service_start
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: return _runAlts(_srvStartAlts, srvName)
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: File "/usr/lib64/python2.7/site-packages/vdsm/tool/service.py", line 350, in _runAlts
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: "%s failed" % alt.func_name, out, err)
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: service.ServiceOperationError: ServiceOperationError: _serviceStart failed
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: vdsm: Dependent network failed to start[FAILED]
Sep 11 06:50:45 localhost systemd-vdsmd[1697]: vdsm: one of the dependent services did not start, error code 1[FAILED]
Sep 11 06:50:45 localhost systemd[1]: vdsmd.service: control process exited, code=exited status=1
Sep 11 06:50:45 localhost systemd[1]: Failed to start Virtual Desktop Server Manager.
Sep 11 06:50:45 localhost systemd[1]: Unit vdsmd.service entered failed state.

Trying to reproduce this right now, will post logs when I succeed.
Comment 2 Fabian Deutsch 2013-09-11 04:31:51 EDT
I couldn't reproduce it. CLosing this bug.

Note You need to log in before you can comment on or make changes to this bug.